am-benchmarks: Add support for am387x-evm machine
[openembedded.git] / recipes / abiword / abiword_2.8.6.bb
blob730fa7b6897f3543a3317cf7aa5d1bf86ecc4dec
1 require abiword-2.5.inc
2 DEPENDS += " loudmouth libwmf-native gtkmathview "
3 RCONFLICTS_${PN} = "abiword-embedded"
5 SRC_URI = "http://www.abisource.com/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz;name=abiword \
6 file://autogen-common.sh \
7 file://nodolt.patch"
9 SRC_URI[abiword.md5sum] = "f883b0a7f26229a9c66fd6a1a94381aa"
10 SRC_URI[abiword.sha256sum] = "d99089a63a6cfc1a6a4a026be9278028d47d224088d24b1853acb67e95683a15"
13 EXTRA_OECONF = " --disable-static \
14 --enable-plugins \
15 --without-gnomevfs \
16 --enable-collab-backend-xmpp \
17 --enable-collab-backend-tcp \
18 --enable-collab-backend-service \
19 --with-libwmf-config=${STAGING_DIR} \
22 do_configure() {
23 install -m 0755 ${WORKDIR}/autogen-common.sh ${S}/autogen-common.sh
24 cd ${S}
25 ./autogen-common.sh
26 autotools_do_configure
29 FILES_${PN} += "${libdir}/libabiword-*.so ${datadir}/mime-info ${datadir}/abiword-${SHRT_VER}/certs ${datadir}/abiword-${SHRT_VER}/ui ${datadir}/abiword-${SHRT_VER}/xsl* ${datadir}/abiword-${SHRT_VER}/mime-info ${datadir}/abiword-${SHRT_VER}/Pr*.xml"
30 FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
31 FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
33 PACKAGES_DYNAMIC = "abiword-meta abiword-plugin-*"
35 python populate_packages_prepend () {
36 abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d)
37 do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
39 metapkg = "abiword-meta"
40 bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d)
41 bb.data.setVar('FILES_' + metapkg, "", d)
42 blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
43 metapkg_rdepends = []
44 packages = bb.data.getVar('PACKAGES', d, 1).split()
45 for pkg in packages[1:]:
46 if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
47 print "Modifying ", pkg
48 metapkg_rdepends.append(pkg)
49 bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
50 bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d)
51 packages.append(metapkg)
52 bb.data.setVar('PACKAGES', ' '.join(packages), d)
55 FILES_${PN}-dev += "${libdir}/abiword-${SHRT_VER}/plugins/*.la"
56 FILES_${PN}-dbg += "${libdir}/abiword-${SHRT_VER}/plugins/.debug"