micro-uclibc.conf: move OVERRIDES to bottom of file
[openembedded.git] / recipes / xmame / xmame_0.95.bb
blob80924ef0c6548c4f316ef0e2c5341f91a38dcc11
1 DESCRIPTION = "Multiple Arcade Machine Emulator based on SDL"
2 LICENSE = "xmame"
3 SECTION = "games"
4 PRIORITY = "optional"
5 DEPENDS = "expat virtual/libsdl libsdl-mixer"
7 SRC_URI = "http://x.mame.net/download/historic/${P}.tar.bz2"
9 inherit flow-lossage
11 EXTRA_OEMAKE=
13 do_compile() {
14 oe_runmake TARGET=mame JOY_SDL=1 SOUND_SDL=1 DISPLAY_METHOD=SDL \
15 CC="${CC}" CXX="${CXX}" CFLAGS="-I. -Isrc -Isrc/include -Isrc/unix ${CFLAGS}" \
16 CXXFLAGS="${CXXFLAGS}" LD="${CC}" LDFLAGS="${LDFLAGS}" \
17 RANLIB="${RANLIB}" MY_CPU="${TARGET_ARCH}" ARCH="${TARGET_OS}" \
18 GLLIBS="" STRIP="${STRIP}" AR="${AR}"
21 do_install() {
22 install -d ${D}${bindir}
23 install -m 0755 xmame.SDL ${D}${bindir}