e-wm: bump SRCREV a bit more than EFL_SRCREV is now
[openembedded.git] / recipes / e17 / e-wm_svn.bb
blob3c35b8585f0f2841a6e07993da6354fdf8694f9d
1 DESCRIPTION = "The Enlightenment Window Manager Version 17"
2 DEPENDS = "eet evas ecore edje efreet edbus eeze"
3 LICENSE = "MIT BSD"
4 SRCNAME = "e"
5 PV = "0.16.999.060+svnr${SRCPV}"
6 PR = "r18"
7 #SRCREV = "${EFL_SRCREV}"
8 #we need newer SRCREV now, remove with next EFL_SRCREV bump
9 SRCREV = "56059"
11 inherit e update-alternatives
13 SRC_URI += "\
14 file://enlightenment_start.oe \
15 file://applications.menu \
16 file://gsm-segfault-fix.patch;maxrev=37617 \
17 file://fix-profiles.diff;maxrev=39889 \
20 SRC_URI_append_openmoko = " file://illume-disable-screensaver.patch"
22 SRC_URI_append_shr = " \
23 file://illume-disable-screensaver.patch \
24 file://wizard-module-skipping.patch \
25 file://illume-flaunch-fix.patch \
26 file://illume-keyboard-flow.patch;maxrev=46549 \
29 EXTRA_OECONF = "\
30 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
31 --with-eet-eet=${STAGING_BINDIR_NATIVE}/eet \
32 --x-includes=${STAGING_INCDIR}/X11 \
33 --x-libraries=${STAGING_LIBDIR} \
34 --enable-simple-x11 \
37 do_configure_prepend() {
38 autopoint
41 do_install_append() {
42 # customising - should rather make this simple upstream
43 install -m 755 ${WORKDIR}/enlightenment_start.oe ${D}/${bindir}
45 install -d ${D}/${datadir}/applications/
46 install -m 644 ${S}/src/modules/fileman/module.desktop ${D}/${datadir}/applications/efm.desktop
47 sed "s#Type=Link#Type=Application#g" -i ${D}/${datadir}/applications/efm.desktop
48 echo "Exec=enlightenment_remote -efm-open-dir" >> ${D}/${datadir}/applications/efm.desktop
49 echo "Terminal=false" >> ${D}/${datadir}/applications/efm.desktop
50 echo "Categories=Application;" >> ${D}/${datadir}/applications/efm.desktop
51 echo "StartupNotify=true" >> ${D}/${datadir}/applications/efm.desktop
52 install -d ${D}/${datadir}/icons/
53 install -m 644 ${S}/data/themes/images/icon_icon_theme.png ${D}/${datadir}/icons/e-module-fileman.png
55 install -d ${D}/${sysconfdir}/xdg/menus
56 install -m 644 ${WORKDIR}/applications.menu ${D}/${sysconfdir}/xdg/menus/
57 for I in `find ${D}/${libdir}/enlightenment -name "*.a" -print`; do rm -f $I; done
58 for I in `find ${D}/${libdir}/enlightenment -name "*.la" -print`; do rm -f $I; done
61 RDEPENDS_${PN} += "\
62 shared-mime-info \
63 mime-support \
64 edje-utils \
65 ${PN}-utils \
68 # Uclibc build don't have 'glibc-utils'
69 RDEPENDS_${PN}_append_libc-glibc = " glibc-utils "
71 # The systray module used to be external, but is part of e-wm now
72 RREPLACES_${PN} = "systray"
74 PACKAGES =+ "\
75 ${PN}-config-default \
76 ${PN}-config-illume \
77 ${PN}-config-illume2 \
78 ${PN}-config-minimalist \
79 ${PN}-config-netbook \
80 ${PN}-config-scaleable \
81 ${PN}-config-standard \
82 ${PN}-theme-default \
83 ${PN}-theme-illume \
84 ${PN}-background-dark-gradient \
85 ${PN}-background-light-gradient \
86 ${PN}-images \
87 ${PN}-icons \
88 ${PN}-other \
89 ${PN}-input-methods \
90 ${PN}-sysactions \
91 ${PN}-utils \
92 ${PN}-menu \
93 efm-desktop-icon \
94 illume-keyboard-default-alpha \
95 illume-keyboard-default-numeric \
96 illume-keyboard-default-terminal \
99 RRECOMMENDS_${PN} = "\
100 ${PN}-config-default \
101 ${PN}-images \
102 ${PN}-icons \
103 ${PN}-other \
104 ${PN}-input-methods \
105 ${PN}-sysactions \
108 PACKAGE_ARCH_${PN}-config-default = "all"
109 PACKAGE_ARCH_${PN}-config-illume = "all"
110 PACKAGE_ARCH_${PN}-config-illume2 = "all"
111 PACKAGE_ARCH_${PN}-config-minimalist = "all"
112 PACKAGE_ARCH_${PN}-config-netbook = "all"
113 PACKAGE_ARCH_${PN}-config-scaleable = "all"
114 PACKAGE_ARCH_${PN}-config-standard = "all"
115 PACKAGE_ARCH_${PN}-theme-default = "all"
116 PACKAGE_ARCH_${PN}-theme-illume = "all"
117 PACKAGE_ARCH_${PN}-background-dark-gradient = "all"
118 PACKAGE_ARCH_${PN}-background-light-gradient = "all"
119 PACKAGE_ARCH_${PN}-images = "all"
120 PACKAGE_ARCH_${PN}-icons = "all"
121 PACKAGE_ARCH_${PN}-other = "all"
122 PACKAGE_ARCH_${PN}-input-methods = "all"
123 PACKAGE_ARCH_${PN}-sysactions = "all"
124 PACKAGE_ARCH_${PN}-menu = "all"
125 PACKAGE_ARCH_efm-desktop-icon = "all"
126 PACKAGE_ARCH_illume-keyboard-default-alpha = "all"
127 PACKAGE_ARCH_illume-keyboard-default-numeric = "all"
128 PACKAGE_ARCH_illume-keyboard-default-terminal = "all"
130 FILES_${PN} = "\
131 ${bindir}/* \
132 ${libdir}/enlightenment/utils/* \
133 ${libdir}/enlightenment/modules/*/*.* \
134 ${libdir}/enlightenment/modules/*/*/* \
135 ${libdir}/enlightenment/*plugins/*/*/* \
136 ${libdir}/enlightenment/preload/e_precache.so \
137 ${datadir}/enlightenment/data/icons \
138 ${datadir}/enlightenment/data/input_methods \
139 ${datadir}/enlightenment/data/config/profile.cfg \
140 ${datadir}/enlightenment/AUTHORS \
141 ${datadir}/enlightenment/COPYING \
142 ${datadir}/xsessions/enlightenment.desktop \
143 ${sysconfdir}/xdg \
146 FILES_${PN}-config-default = "${datadir}/enlightenment/data/config/default"
147 FILES_${PN}-config-illume = "${datadir}/enlightenment/data/config/illume"
148 FILES_${PN}-config-illume2 = "${datadir}/enlightenment/data/config/illume-home"
149 FILES_${PN}-config-minimalist = "${datadir}/enlightenment/data/config/minimalist"
150 FILES_${PN}-config-netbook = "${datadir}/enlightenment/data/config/netbook"
151 FILES_${PN}-config-scaleable = "${datadir}/enlightenment/data/config/scaleable"
152 FILES_${PN}-config-standard = "${datadir}/enlightenment/data/config/standard"
153 FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj"
154 FILES_${PN}-theme-illume = "${datadir}/enlightenment/data/themes/illume.edj"
155 FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj"
156 FILES_${PN}-background-dark-gradient = "${datadir}/enlightenment/data/backgrounds/Dark_Gradient.edj"
157 FILES_${PN}-background-light-gradient = "${datadir}/enlightenment/data/backgrounds/Light_Gradient.edj"
158 FILES_${PN}-images = "${datadir}/enlightenment/data/images"
159 FILES_${PN}-icons = "${datadir}/enlightenment/data/icons"
160 FILES_${PN}-other = "${datadir}/enlightenment/data/other"
161 FILES_${PN}-input-methods = "${datadir}/enlightenment/data/input_methods"
162 FILES_${PN}-sysactions = "${sysconfdir}/enlightenment/sysactions.conf"
163 FILES_${PN}-utils = "${libdir}/enlightenment/utils/*"
164 FILES_${PN}-menu = "${sysconfdir}/xdg/menus/applications.menu"
166 FILES_efm-desktop-icon = "\
167 ${datadir}/applications/efm.desktop \
168 ${datadir}/icons/e-module-fileman.png \
171 KEYBOARDS_DIR="${libdir}/enlightenment/modules/illume-keyboard/keyboards"
172 FILES_illume-keyboard-default-alpha = "\
173 ${KEYBOARDS_DIR}/Default.kbd \
174 ${KEYBOARDS_DIR}/alpha.png \
176 FILES_illume-keyboard-default-numeric = "\
177 ${KEYBOARDS_DIR}/Numbers.kbd \
178 ${KEYBOARDS_DIR}/numeric.png \
180 FILES_illume-keyboard-default-terminal = "\
181 ${KEYBOARDS_DIR}/Terminal.kbd \
182 ${KEYBOARDS_DIR}/qwerty.png \
185 RRECOMMENDS_${PN}-config-default = "${PN}-theme-default"
186 RRECOMMENDS_${PN}-config-illume = "\
187 ${PN}-theme-illume \
188 illume-keyboard-default-alpha \
189 illume-keyboard-default-numeric \
190 illume-keyboard-default-terminal \
192 RRECOMMENDS_${PN}-config-illume2 = "\
193 ${PN}-theme-illume \
194 illume-keyboard-default-alpha \
195 illume-keyboard-default-numeric \
196 illume-keyboard-default-terminal \
199 RRECOMMENDS_${PN}-config-minimalist = "\
200 ${PN}-background-light-gradient \
201 ${PN}-theme-default \
203 RRECOMMENDS_${PN}-config-netbook = "\
204 ${PN}-background-dark-gradient \
205 ${PN}-theme-default \
207 RRECOMMENDS_${PN}-config-scaleable = "${PN}-theme-default"
208 RRECOMMENDS_${PN}-config-standard = "${PN}-theme-default"
210 FILES_${PN}-dbg += "\
211 ${libdir}/enlightenment/modules/*/*/.debug/ \
212 ${libdir}/enlightenment/preload/.debug/ \
213 ${libdir}/enlightenment/utils/.debug/ \
214 ${libdir}/enlightenment/*plugins/*/*/.debug \
217 FILES_${PN}-doc += "\
218 ${datadir}/enlightenment/doc \
221 CONFFILES_${PN}-menu = "${sysconfdir}/xdg/menus/applications.menu"
222 CONFFILES_${PN}-sysactions = "/etc/enlightenment/sysactions.conf"
224 ALTERNATIVE_PATH = "${bindir}/enlightenment_start.oe"
225 ALTERNATIVE_NAME = "x-window-manager"
226 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
227 ALTERNATIVE_PRIORITY = "16"