libxine: update to version 1.1.19
[openembedded.git] / recipes / gnuchess / gnuchess_5.021.bb
blobc3579c4602d4822c528ebfc0227d8b89ad8363a0
1 DESCRIPTION = "Gnuchess is a chess playing engine."
2 SECTION = "console"
3 PRIORITY = "optional"
4 MAINTAINER = "Andreas Holzer <a.holzer@cheese.at>"
5 LICENSE = "GPL"
6 PR = "r1"
7 RSUGGESTS_${PN} = "xboard"
9 TARGET_CC_ARCH += "${LDFLAGS}"
11 SRC_URI = "http://members.cheese.at/woody/fltk-chess/gnuchess_5.02.tar.gz \
12 file://gnuchess.desktop \
13 file://gnuchess.png \
14 file://gnuchess.sh \
16 S = "${WORKDIR}/chess-5.02/src"
18 inherit autotools
20 do_install() {
21 install -d ${D}${bindir}
22 install -d ${D}${datadir}/pixmaps/
23 install -d ${D}${datadir}/applications/
24 install -m 0755 ${WORKDIR}/gnuchess.sh ${D}${bindir}
25 install -m 0644 ${WORKDIR}/gnuchess.png ${D}${datadir}/pixmaps/
26 install -m 0644 ${WORKDIR}/gnuchess.desktop ${D}${datadir}/applications/
27 install -D ${S}/gnuchess ${D}${bindir}/gnuchess
30 SRC_URI[md5sum] = "01a9e1dc12613543f10ca3bc09acc0af"
31 SRC_URI[sha256sum] = "64483bf3e98124e3490509a6054da0ff70b69ca0baa04f53444d7cf054deee06"