midori: add 0.2.4
[openembedded.git] / recipes / prboom / prboom_2.5.0.bb
blobf775855d934c13873f47c93032f721ab82a90a68
1 DESCRIPTION = "A Doom Clone based on SDL"
2 SECTION = "games"
3 PRIORITY = "optional"
4 DEPENDS = "virtual/libsdl libsdl-mixer libsdl-net"
5 LICENSE = "GPL"
7 PR = "r1"
8 RRECOMMENDS = "freedoom"
10 SRC_URI = "${SOURCEFORGE_MIRROR}/prboom/prboom-${PV}.tar.gz \
13 inherit autotools
15 EXTRA_OECONF = " --disable-gl --disable-cpu-opt --without-x --disable-sdltest"
17 do_install() {
18 install -d ${D}${bindir} \
19 ${D}${datadir}/games/doom
21 install -m 0755 src/prboom ${D}${bindir}/prboom
22 install -m 0644 data/prboom.wad ${D}${datadir}/games/doom/
25 FILES_${PN} += "${datadir}/games/doom/prboom.wad"