midori: add 0.2.4
[openembedded.git] / recipes / ppp-dialin / ppp-dialin_0.1.bb
blob51a4a2b32d5887b9e574efa76079758c5ae24fbd
1 SECTION = "console/network"
2 DESCRIPTION = "Enables PPP dial-in through a serial connection"
3 DEPENDS = "ppp"
4 RDEPENDS = "ppp"
5 PR = "r6"
6 LICENSE = "MIT"
8 SRC_URI = "file://host-peer \
9 file://ppp-dialin"
11 do_install() {
12 install -d ${D}${sysconfdir}/ppp/peers
13 install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
15 install -d ${D}${sbindir}
16 install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
19 PACKAGE_ARCH = "all"
21 pkg_postinst() {
22 if test "x$D" != "x"; then
23 exit 1
24 else
25 grep "^ppp:" /etc/passwd > /dev/null || adduser --system --home /dev/null --no-create-home --empty-password --ingroup nogroup -s ${sbindir}/ppp-dialin ppp
29 pkg_postrm() {
30 if test "x$D" != "x"; then
31 exit 1
32 else
33 deluser ppp || true