midori: add 0.2.4
[openembedded.git] / recipes / netbase / netbase_4.21.bb
blobc8b4d198690d3b39f1d346e9731590871b2c7844
1 DESCRIPTION = "This package provides the necessary \
2 infrastructure for basic TCP/IP based networking."
3 SECTION = "base"
4 LICENSE = "GPL"
5 PR = "r40"
7 inherit update-rc.d
9 SRC_URI_OVERRIDES_PACKAGE_ARCH = "1"
11 INITSCRIPT_NAME = "networking"
12 INITSCRIPT_PARAMS = "start 40 S . stop 40 0 6 1 ."
13 # On MNCI etc, start very late so that our own apps come up faster
14 INITSCRIPT_PARAMS_openmn = "start 85 1 2 3 4 5 . stop 85 0 6 1 ."
15 # On SlugOS (NSLU2) delay the stop until after network apps have exited
16 # Do not stop in single user - there's no way to sulogin!
17 INITSCRIPT_PARAMS_slugos = "start 42 S 0 6 ."
19 SRC_URI = "\
20 http://developer.irexnet.com/pub/iOn/Sources/1.0/Third%20party/all/netbase-${PV}.tar.gz \
21 file://options \
22 file://init \
23 file://hosts \
24 file://interfaces \
25 file://if-pre-up.d \
26 file://if-up.d \
27 file://if-down.d \
28 file://if-post-down.d \
31 do_install () {
32 install -d ${D}${sysconfdir}/init.d
33 install -d ${D}${sbindir}
34 install -d ${D}${mandir}/man8
35 install -d ${D}${sysconfdir}/network/if-pre-up.d
36 install -d ${D}${sysconfdir}/network/if-up.d
37 install -d ${D}${sysconfdir}/network/if-down.d
38 install -d ${D}${sysconfdir}/network/if-post-down.d
40 for dir in if-pre-up.d if-up.d if-down.d if-post-down.d
42 for script in `ls -1 "${WORKDIR}/${dir}"`
43 do
44 install -m 0755 "${WORKDIR}/${dir}/${script}" "${D}${sysconfdir}/network/${dir}"
45 done
46 done
48 install -m 0644 ${WORKDIR}/options ${D}${sysconfdir}/network/options
49 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/networking
50 install -m 0644 ${WORKDIR}/hosts ${D}${sysconfdir}/hosts
51 install -m 0644 etc-rpc ${D}${sysconfdir}/rpc
52 install -m 0644 etc-protocols ${D}${sysconfdir}/protocols
53 install -m 0644 etc-services ${D}${sysconfdir}/services
54 if [ "${ONLINE_PACKAGE_MANAGEMENT}" != "none" ]; then
55 install -m 0755 update-inetd ${D}${sbindir}/
56 install -m 0644 update-inetd.8 ${D}${mandir}/man8/
58 install -m 0644 ${WORKDIR}/interfaces ${D}${sysconfdir}/network/interfaces
61 CONFFILES_${PN} = "${sysconfdir}/network/options ${sysconfdir}/hosts \
62 ${sysconfdir}/network/interfaces ${sysconfdir}/rpc \
63 ${sysconfdir}/protocols ${sysconfdir}/services"