midori: add 0.2.4
[openembedded.git] / recipes / iptraf / iptraf_3.0.0.bb
blobbbfad48d3876fb7624d4027ccb5237549cd54618
1 DESCRIPTION = "Heavyweight console network bandwidth monitor"
2 LICENSE = "GPLv2"
3 DEPENDS = "ncurses"
4 PR = "r0"
6 SRC_URI = " \
7 ${DEBIAN_MIRROR}/main/i/iptraf/iptraf_${PV}.orig.tar.gz \
8 ${DEBIAN_MIRROR}/main/i/iptraf/iptraf_3.0.0-6.diff.gz;patch=1 \
9 file://support-makefile.patch;patch=1 \
12 # iptraf will store user filters etc. in /var/run/iptraf, which is probably
13 # volatile.
14 EXTRA_OEMAKE_append = " \
15 TARGET=${bindir} WORKDIR=${localstatedir}/run/iptraf DESTDIR=${D} \
16 INCLUDEDIR=-I../support \
19 do_compile(){
20 oe_runmake -C ${S}/src
23 do_install() {
24 install -d ${D}${bindir}
25 install -m 0755 ${S}/src/iptraf ${D}${bindir}
26 install -m 0755 ${S}/src/rvnamed ${D}${bindir}
28 install -d ${D}${mandir}/man8
29 install -m 0644 ${S}/Documentation/iptraf.8 ${D}${mandir}/man8
32 PACKAGES =+ "${PN}-dns"
33 DESCRIPTION_${PN}-dns = "Asynchronous reverse DNS lookup daemon for iptraf"
34 FILES_${PN}-dns = "${bindir}/rvnamed"