midori: add 0.2.4
[openembedded.git] / recipes / flumotion / flumotion_0.4.1.bb
blobc746da6c8fcd3f3f4a1f563735366019ad8a511c
1 DESCRIPTION = "Fluendo Streaming Server"
2 LICENSE = "GPL"
3 DEPENDS = "gstreamer python-imaging python-gst python-twisted python-pygtk"
4 RDEPENDS = "python-resource python-pprint python-threading \
5 python-imaging python-xml python-curses \
6 python-compression python-fcntl python-pygobject \
7 python-pickle python-netclient python-datetime \
8 python-crypt python-twisted-core python-twisted-web \
9 python-lang python-zopeinterface python-textutils \
10 python-gst python-misc"
11 RDEPENDS_${PN}-gui = "${PN} python-pygtk python-pycairo"
12 PR = "r10"
14 SRC_URI = "http://www.flumotion.net/src/flumotion/flumotion-${PV}.tar.bz2 \
15 file://python-path.patch;patch=1 \
16 file://no-check-for-python-stuff.patch;patch=1"
18 inherit autotools distutils-base pkgconfig
20 export EPYDOC = "no"
22 EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
24 PACKAGES =+ "flumotion-gui"
26 FILES_${PN}-dbg += "${libdir}/flumotion/python/flumotion/extern/*/.debug/*"
27 FILES_${PN} = "${bindir} ${sbindir} ${libdir}/flumotion"
28 FILES_${PN}-dev += "${libdir}/pkgconfig"
29 FILES_${PN}-gui = "${bindir}/flumotion-admin ${bindir}/flumotion-tester \
30 ${libdir}/flumotion/python/flumotion/admin/gtk \
31 ${libdir}/flumotion/python/flumotion/component/*/admin_gtk* \
32 ${libdir}/flumotion/python/flumotion/component/*/*/admin_gtk* \
33 ${libdir}/flumotion/python/flumotion/extern/*.py* \
34 ${libdir}/flumotion/python/flumotion/extern/fdpass/*.py* \
35 ${libdir}/flumotion/python/flumotion/extern/fdpass/fdpass.so \
36 ${libdir}/flumotion/python/flumotion/extern/pytrayicon/*.py* \
37 ${libdir}/flumotion/python/flumotion/extern/pytrayicon/pytrayicon.so \
38 ${libdir}/flumotion/python/flumotion/manager \
39 ${libdir}/flumotion/python/flumotion/ui \
40 ${libdir}/flumotion/python/flumotion/wizard \
41 ${datadir}/pixmaps ${datadir}/flumotion ${datadir}/applications"