mtd-utils-tests: add package
[openembedded.git] / classes / qpf.bbclass
blob67761bd4be9736a06f779f14a0e4105aca7293fe
1 PACKAGE_ARCH = "all"
3 do_configure() {
4         :
7 do_compile() {
8         :
11 pkg_postinst_fonts() {
12 . /etc/profile
13 ${sbindir}/update-qtfontdir
16 pkg_postrm_fonts() {
17 . /etc/profile
18 ${sbindir}/update-qtfontdir -f
21 python populate_packages_prepend() {
22         postinst = bb.data.getVar('pkg_postinst_fonts', d, 1)
23         postrm   = bb.data.getVar('pkg_postrm_fonts', d, 1)
24         fontdir  = bb.data.getVar('palmtopdir', d, 1) + '/lib/fonts'
25         pkgregex = "^([a-z-]*_[0-9]*).*.qpf$"
26         pkgpattern = bb.data.getVar('QPF_PKGPATTERN', d, 1) or 'qpf-%s'
27         pkgdescription = bb.data.getVar('QPF_DESCRIPTION', d, 1) or 'QPF font %s'
29         do_split_packages(d, root=fontdir, file_regex=pkgregex, output_pattern=pkgpattern, 
30                           description=pkgdescription, postinst=postinst, postrm=postrm, recursive=True, hook=None, 
31                           extra_depends='qpf-font-common')