mtd-utils-tests: add package
[openembedded.git] / classes / gettext.bbclass
bloba1e00e72c1fb2cb2bfb27e29d62bc5c4ccf55a70
1 def gettext_after_parse(d):
2     import bb
3     # Remove the NLS bits if USE_NLS is no.
4     if bb.data.getVar('USE_NLS', d, 1) == 'no':
5         cfg = oe_filter_out('^--(dis|en)able-nls$', bb.data.getVar('EXTRA_OECONF', d, 1) or "", d)
6         cfg += " --disable-nls"
7         depends = bb.data.getVar('DEPENDS', d, 1) or ""
8         bb.data.setVar('DEPENDS', oe_filter_out('^(virtual/libiconv|virtual/libintl)$', depends, d), d)
9         bb.data.setVar('EXTRA_OECONF', cfg, d)
11 python () {
12     gettext_after_parse(d)
15 DEPENDS =+ "gettext-native"
16 EXTRA_OECONF += "--enable-nls"