unzip: use BBCLASSEXTEND now
[openembedded.git] / recipes / gnome-mplayer / gecko-mediaplayer_svn.bb
blob1bae6fa40343b0bec623fe7c6375b755ed94755d
1 DESCRIPTION = "Gecko plugin for gnome-mplayer"
2 HOMEPAGE = "http://dekorte.homeip.net/download/gecko-mediaplayer/"
3 LICENSE = "GPL"
4 DEPENDS = "firefox gtk+ gconf dbus-glib"
5 RDEPENDS = "firefox gnome-mplayer"
7 PV = "0.9.9.2+${SRCPV}"
8 SRCREV = "387"
10 inherit autotools
12 SRC_URI = "svn://gecko-mediaplayer.googlecode.com/svn/;module=trunk;proto=http \
13 file://extensions \
16 S = "${WORKDIR}/trunk"
18 # XUL changed API badly, so we need to choose between pre 3.6 and post 3.6 firefox :(
19 EXTRA_OECONF = " --enable-new-libxul=yes "
20 TARGET_CC_ARCH += " -DHAVE_NEW_XULRUNNER=1 "
22 do_install_append() {
23 cp -dpR ${WORKDIR}/extens* ${D}${libdir}/mozilla/
26 PACKAGES =+ "${PN}-firefox-hack"
27 RDEPENDS_${PN}-firefox-hack = "${PN}"
28 FILES_${PN}-firefox-hack = "${libdir}/mozilla/extensions"
30 FILES_${PN} += "${sysconfdir}/* \
31 ${libdir}/mozilla/*"
32 FILES_${PN}-dbg += "${libdir}/mozilla*/plugins/.debug/*"
34 pkg_postinst_${PN}-firefox-hack() {
35 for firefoxdir in $D${libdir}/firefox-* ; do
36 if [ -e $firefoxdir/extensions/ ] ; then
37 ln -sf ${libdir}/mozilla/extensions/flash@alwaysinnovating.com $firefoxdir/extensions/
39 done