linux-kexecboot_2.6.24: readd boot logo to tosa defconfig
[openembedded.git] / recipes / tasks / task-opie-16mb.bb
blob859a0f5feb6351180d6d6ae6f50640d0f9d5900c
1 DESCRIPTION = "Tasks for small OPIE image"
2 SECTION = "opie/base"
3 LICENSE = "MIT"
4 PR = "r3"
6 inherit task
8 PACKAGES = "task-opie-16mb-base \
9 task-opie-16mb-applets \
10 task-opie-16mb-inputmethods \
11 task-opie-16mb-settings \
12 task-opie-16mb-apps \
13 task-opie-16mb-pim \
17 # Dependencies to get the launcher up and running
19 RDEPENDS_task-opie-16mb-base = "opie-init opie-alarm opie-qcop opie-qss opie-quicklauncher \
20 opie-taskbar opie-pics opie-sounds opie-freetype opie-taskbar-images-320x240 \
21 ttf-dejavu-sans ttf-dejavu-sans-mono"
24 # things for reasonable bootstrap image
26 RDEPENDS_task-opie-16mb-applets = "opie-aboutapplet opie-clockapplet opie-suspendapplet \
27 opie-homeapplet opie-rotateapplet \
28 opie-brightnessapplet opie-volumeapplet \
29 opie-screenshotapplet \
30 ${@base_contains("COMBINED_FEATURES", "irda", "opie-irdaapplet", "",d)} \
31 ${@base_contains("MACHINE_FEATURES", "apm", "opie-batteryapplet", "",d)} \
32 ${@base_contains("COMBINED_FEATURES", "pcmcia", "opie-cardapplet", "",d)} \
33 ${@base_contains("MACHINE_FEATURES", "keyboard", "opie-vtapplet opie-logoutapplet", "",d)}"
35 PACKAGE_ARCH_task-opie-16mb-applets = "${MACHINE_ARCH}"
38 # clamshell models can benefit from the autorotate applet
40 RDEPENDS_task-opie-16mb-applets_append_c7x0 = " opie-autorotateapplet"
41 RDEPENDS_task-opie-16mb-applets_append_spitz = " opie-autorotateapplet"
42 RDEPENDS_task-opie-16mb-applets_append_akita = " opie-autorotateapplet"
44 RDEPENDS_task-opie-16mb-inputmethods = "opie-multikey"
46 RDEPENDS_task-opie-16mb-settings = "opie-packagemanager opie-light-and-power opie-appearance \
47 opie-systemtime opie-networksettings opie-button-settings \
48 opie-icon-reload opie-launcher-settings opie-security \
49 opie-securityplugin-pin"
51 RDEPENDS_task-opie-16mb-apps = "opie-console opie-clock opie-backup opie-sysinfo \
52 opie-advancedfm"
54 RDEPENDS_task-opie-16mb-pim = "opie-addressbook opie-datebook opie-drawpad \
55 opie-search opie-textedit opie-today opie-todo"