linux-kexecboot_2.6.24: readd boot logo to tosa defconfig
[openembedded.git] / recipes / tasks / angstrom-task-lxde.bb
blobeb474775af881752e70e8ef22ee2513340d56af8
1 DESCRIPTION = "Tasks for an LXDE based image"
3 inherit task
5 # Most of these tasks are arch independant
6 PACKAGE_ARCH = "all"
8 XSERVER ?= "xserver-xorg \
9 xf86-input-evdev \
10 xf86-input-mouse \
11 xf86-video-fbdev \
12 xf86-input-keyboard \
15 PACKAGES += "task-lxde-apps task-lxde-xserver task-lxde-xserver-base"
17 RDEPENDS_task-lxde-apps = " \
18 pcmanfm \
19 lxpanel \
20 lxsession-lite \
21 lxde-common \
22 openbox \
23 leafpad \
24 gpicview \
27 RDEPENDS_task-lxde-xserver-base = " \
28 dbus-x11 \
29 desktop-file-utils \
30 iso-codes \
31 mime-support \
32 notification-daemon inotify-tools \
33 xauth \
34 xdg-utils \
35 xhost \
36 xinetd \
37 xinit \
38 xlsfonts \
39 xrandr \
40 xrdb \
41 xrefresh \
42 xset \
43 xvinfo \
46 RDEPENDS_task-lxde-xserver = " \
47 ${XSERVER} \
50 PACKAGE_ARCH_task-lxde-xserver = "${MACHINE_ARCH}"
52 RDEPENDS_${PN} = " \
53 task-lxde-xserver-base \
56 RRECOMMENDS_${PN} = " \
57 task-lxde-xserver \