1 # Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
2 # Released under the MIT license (see packages/COPYING)
4 #This class handles all the intricasies of getting the required files from the
5 #ISE/EDK/project to the kernel and prepare the kernel for compilation.
6 #The Xilinx EDK supports 2 different architectures : PowerPC (ppc 405) and Microblaze
7 #Only the PowerPC BSP has been tested so far
8 #For this to work correctly you need to add XILINX_BSP_PATH and XILINX_BOARD to your
10 #XILINX_BSP_PATH should have the complete path to your project dir
11 #XILINX_BOARD should have the board type i.e ML403
13 #Currently supported boards
17 do_configure_prepend() {
20 #first check that the XILINX_BSP_PATH and XILINX_BOARD have been defined in local.conf
21 if [ -z "${XILINX_BSP_PATH}" ]; then
22 oefatal "XILINX_BSP_PATH not defined ! Exiting..."
26 if [ -z "${XILINX_BOARD}" ]; then
27 oefatal "XILINX_BOARD not defined ! Exiting"
32 #now depending on the board type and arch do what is nessesary
34 case "${XILINX_BOARD}" in
36 oenote "ML403 board setup"
37 cp -pPR ${XILINX_BSP_PATH}/ppc405_0/libsrc/linux_2_6_v1_00_a/linux/arch/ppc/platforms/4xx/xparameters/xparameters_ml40x.h \
38 ${S}/arch/ppc/platforms/4xx/xparameters/xparameters_ml403.h
42 oefatal "! Unknow Xilinx board ! Exiting..."