nfs-utils: Drop do_ccompile
[openembedded.git] / recipes / nfs-utils / nfs-utils_1.1.2.bb
blob45ff4eaa2839aae706d600df634491808348f842
1 DESCRIPTION = "userspace utilities for kernel nfs"
2 PRIORITY = "optional"
3 SECTION = "console/network"
4 LICENSE = "GPL"
6 PR = "r9"
8 DEPENDS = "util-linux-ng tcp-wrappers libevent"
10 SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
11 file://nfs-utils-tools-unset-cflags.patch \
12 file://nfs-utils-uclibc-compile.patch \
13 file://nfs-utils-S_ISREG-missing-include.patch \
14 file://nfsserver \
17 S = "${WORKDIR}/nfs-utils-${PV}/"
19 PARALLEL_MAKE = ""
21 # Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
22 # pull in the remainder of the dependencies.
23 RDEPENDS_${PN} = "portmap"
24 RRECOMMENDS_${PN} = "kernel-module-nfsd"
26 INITSCRIPT_NAME = "nfsserver"
27 # The server has no dependencies at the user run levels, so just put
28 # it in at the default levels. It must be terminated before the network
29 # in the shutdown levels, but that works fine.
30 INITSCRIPT_PARAMS = "defaults"
32 inherit autotools update-rc.d
34 EXTRA_OECONF = "--with-statduser=nobody \
35 --enable-nfsv3 \
36 --disable-nfsv4 \
37 --disable-gss \
38 --with-statedir=/var/lib/nfs"
40 INHIBIT_AUTO_STAGE = "1"
42 do_install_append() {
43 install -d ${D}${sysconfdir}/init.d
44 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
46 rm ${D}${sbindir}/rpcdebug
49 PACKAGES =+ "nfs-utils-client"
50 FILES_nfs-utils-client = "${base_sbindir}/*mount.nfs*"
52 SRC_URI[md5sum] = "76ee9274c2b867839427eba91b327f03"
53 SRC_URI[sha256sum] = "1d09b1c133e4eed9d2df07ead4eba813e6993875c39e66d7b4081287029d4033"