1 DESCRIPTION
= "Matchbox session files for Openmoko"
2 SECTION
= "openmoko/base"
3 RDEPENDS_$
{PN
} = "matchbox-panel-2 matchbox-wm openmoko-today gconf"
4 PV
= "0.1+svnr${SRCPV}"
9 SRC_URI
= "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE};module=etc;proto=http \
14 cp
-R $
{S
}/etc $
{D
}/$
{sysconfdir
}
15 rm
-fR $
{D
}/$
{sysconfdir
}/.svn
16 rm
-fR $
{D
}/$
{sysconfdir
}/matchbox
/.svn
17 chmod
-R
755 $
{D
}/$
{sysconfdir
}
18 # DEMO only. Need
to handle this differently in actual production images
19 install
-m
0755 $
{WORKDIR
}/session $
{D
}/$
{sysconfdir
}/matchbox
/session
22 pkg_postinst_openmoko
-session
() {
24 if [ "x$D" != "x" ]; then
28 gconftool
-2 --config
-source
=xml
::$D$
{sysconfdir
}/gconf
/gconf.xml.defaults
--direct
--type string --set
/desktop
/openmoko
/interface
/theme openmoko
-standard