u-boot-bug: Drop do_stage (not needed), add package_stagefile_shell to deploy
[openembedded.git] / recipes / openmoko-base / openmoko-session_svn.bb
blob19f1ce4715e221a2e605ea969a4f20dda615b8ef
1 DESCRIPTION = "Matchbox session files for Openmoko"
2 SECTION = "openmoko/base"
3 RDEPENDS_${PN} = "matchbox-panel-2 matchbox-wm openmoko-today gconf"
4 PV = "0.1+svnr${SRCPV}"
5 PR = "r1"
7 inherit openmoko-base
9 SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE};module=etc;proto=http \
10 file://session"
11 S = "${WORKDIR}"
13 do_install() {
14 cp -R ${S}/etc ${D}/${sysconfdir}
15 rm -fR ${D}/${sysconfdir}/.svn
16 rm -fR ${D}/${sysconfdir}/matchbox/.svn
17 chmod -R 755 ${D}/${sysconfdir}
18 # DEMO only. Need to handle this differently in actual production images
19 install -m 0755 ${WORKDIR}/session ${D}/${sysconfdir}/matchbox/session
22 pkg_postinst_openmoko-session () {
23 #!/bin/sh -e
24 if [ "x$D" != "x" ]; then
25 exit 1
28 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/openmoko/interface/theme openmoko-standard
31 PACKAGE_ARCH = "all"