u-boot-bug: Drop do_stage (not needed), add package_stagefile_shell to deploy
[openembedded.git] / recipes / kexec-tools / kexec-tools-klibc_2.0.2.bb
blobe73770cf572b4e44d48238d867e76c4880a9085d
1 # the binaries are statically linked against klibc
2 require kexec-tools_${PV}.inc
4 PR = "r1"
5 DEPENDS = "klibc"
7 FILESPATHPKG =. "kexec-tools-${PV}:"
9 SRC_URI += "file://headers.patch \
10 file://elf.patch \
11 file://errno.patch \
12 file://string.patch \
13 file://syscall.patch \
14 file://other.patch \
17 S = "${WORKDIR}/kexec-tools-${PV}"
19 EXTRA_OECONF = " --without-zlib"
20 export CC=${TARGET_PREFIX}klcc
22 # reset inherited OE flags to avoid e.g. ggdb3 and keep size small
23 export CFLAGS=""
24 export CPPFLAGS=""
25 export LDFLAGS=""
27 PACKAGES =+ "kexec-klibc kdump-klibc"
29 FILES_kexec-klibc = "${sbindir}/kexec"
30 FILES_kdump-klibc = "${sbindir}/kdump"