u-boot-bug: Drop do_stage (not needed), add package_stagefile_shell to deploy
[openembedded.git] / recipes / gnokii / gnokii_0.6.14.bb
blob569d9a2b5977c1ec178a6d81a47888aef9df9714
1 LICENSE = "GPL"
2 DESCRIPTION = "Cellphone tools and driver software"
3 SRC_URI = "http://www.gnokii.org/download/gnokii/gnokii-${PV}.tar.bz2 \
4 file://configure.patch"
6 DEPENDS = "libxpm gtk+"
8 inherit autotools pkgconfig
10 PARALLEL_MAKE = ""
12 PACKAGES += "libgnokii libgnokii-dev"
14 FILES_${PN} = "${bindir} ${sbindir}"
15 FILES_libgnokii-dev = "${includedir} ${libdir}/lib*.so ${libdir}/*.la \
16 ${libdir}/*.a ${libdir}/*.o ${libdir}/pkgconfig \
17 /lib/*.a /lib/*.o ${datadir}/aclocal"
18 FILES_${PN}-dev = ""
19 FILES_libgnokii = "${libdir}/libgnokii.so.*"
21 do_stage() {
22 autotools_stage_includes
24 oe_libinstall -C common -so libgnokii ${STAGING_LIBDIR}
28 SRC_URI[md5sum] = "89449d613c7a7e765a0d8da57ef1bb88"
29 SRC_URI[sha256sum] = "cea63cddf79864d306198c7a84091af0b4685816b352ae253a3e2bfac5e67cb7"