u-boot-bug: Drop do_stage (not needed), add package_stagefile_shell to deploy
[openembedded.git] / recipes / cpio / cpio_2.5.bb
blobb4504bac226a3f160ae1de1cc13e6a0a940caaa7
1 DESCRIPTION = "GNU cpio is a program to manage archives of files."
2 HOMEPAGE = "http://www.gnu.org/software/cpio/"
3 SECTION = "console"
4 LICENSE = "GPL"
5 PR = "r5"
7 DEPENDS += " texinfo-native "
9 SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \
10 file://install.patch"
11 S = "${WORKDIR}/cpio-${PV}"
13 inherit autotools
15 do_install () {
16 autotools_do_install
17 install -d ${D}${base_bindir}/
18 mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio.${PN}"
19 case ${TARGET_OS} in
20 *-uclibc*) ;;
21 *) mv "${D}${libexecdir}/rmt" "${D}${libexecdir}/rmt.${PN}" ;;
22 esac
25 pkg_postinst_${PN} () {
26 update-alternatives --install ${base_bindir}/cpio cpio cpio.${PN} 100
27 if [ -f ${libexecdir}/rmt.${PN} ]
28 then
29 update-alternatives --install ${libexecdir}/rmt rmt rmt.${PN} 50
33 pkg_prerm_${PN} () {
34 update-alternatives --remove cpio cpio.${PN}
35 if [ -f ${libexecdir}/rmt.${PN} ]
36 then
37 update-alternatives --remove rmt rmt.${PN}
41 SRC_URI[md5sum] = "e02859af1bbbbd73fcbf757acb57e0a4"
42 SRC_URI[sha256sum] = "dbf79293d0cafa7d7a3a266c2b0b90c00d556e7b3185d4243c74153291da24c8"