u-boot-bug: Drop do_stage (not needed), add package_stagefile_shell to deploy
[openembedded.git] / recipes / compcache / compcache_0.6.bb
bloba3a0be791e14c1628770ed104994c3d6ba744fe5
1 HOMEPAGE = "http://code.google.com/p/compcache"
2 DESCRIPTION = "Kernel drivers version 0.6x and related tool for the compcache (compressed in-memory swap device for linux)"
3 LICENSE = "GPLv2"
5 inherit module
7 SRC_URI = "http://compcache.googlecode.com/files/${PN}-${PV}.tar.gz \
8 file://003-compcache-0.6-KERNELDIR.patch \
9 file://001-compcache-rzscontrol-cross-compile.patch \
10 file://002-compcache-modules-install.patch \
12 TARGET_CC_ARCH += "${LDFLAGS}"
14 PACKAGES = "kernel-module-compcache compcache-utils compcache-utils-dbg compcache-utils-doc"
16 FILES_kernel-module-compcache = ${FILES_compcache}
17 FILES_compcache-utils = "${bindir}/rzscontrol"
18 FILES_compcache-utils-dbg = "${bindir}/.debug/rzscontrol"
19 FILES_compcache-utils-doc = "${mandir}/man1/rzscontrol.1"
21 do_install_prepend() {
22 mkdir -p ${D}${bindir}
23 mkdir -p ${D}${mandir}/man1
24 install -m 0755 ${S}/sub-projects/rzscontrol/rzscontrol ${D}${bindir}
25 install -m 0644 ${S}/sub-projects/rzscontrol/man/rzscontrol.1 ${D}${mandir}/man1
29 SRC_URI[md5sum] = "0a574643c0eb857b946adcd5d5a22eb0"
30 SRC_URI[sha256sum] = "e5f697be6c1b7bfb9ac9ba5b8d836ff20f880c161f998c482caba83caf443c0c"