u-boot-bug: Drop do_stage (not needed), add package_stagefile_shell to deploy
[openembedded.git] / recipes / bootchart / bootchart_0.9.bb
blobe9fdd3a9b76ba62fba021975433a5c607aef9e06
1 DESCRIPTION = "Bootchart is a tool for performance analysis and visualization of the GNU/Linux boot process."
2 LICENSE = "GPLv2"
3 HOMEPAGE = "http://www.bootchart.org/"
4 PR = "r2"
6 #this only installs the loggers, you will need to run the renderers on your workstation
7 #boot with 'init=/sbin/bootchartd' and do '/sbin/bootchartd stop' to end the logging
9 #needed for a real /bin/sh and /bin/sleep
10 DEPENDS = "bash coreutils acct"
11 RDEPENDS_${PN} = "bash coreutils acct"
13 #this is a plain shell script
14 PACKAGE_ARCH = "all"
16 SRC_URI = "${SOURCEFORGE_MIRROR}/bootchart/bootchart-${PV}.tar.bz2\
17 file://handheld.patch"
20 do_install() {
21 install -d ${D}/sbin
22 install -d ${D}/etc
23 install -d ${D}/bootchart
24 install -m 755 ${S}/script/bootchartd ${D}/sbin
25 install -m 644 ${S}/script/bootchartd.conf ${D}/etc
29 SRC_URI[md5sum] = "4be91177d19069e21beeb106f2f77dff"
30 SRC_URI[sha256sum] = "7738399ecfcfb2242e9f99a316b13a5f59e89052de05074dbf705ccf4edc327d"