apr-util: Switch to getting libtool from PATH
[openembedded.git] / recipes / irssi / irssi_0.8.10.bb
blob68634f7a77549a0fe72912bea1012c80efedb815
1 DESCRIPTION = "Irssi is a modular IRC client with Perl scripting."
2 HOMEPAGE = "http://irssi.org/"
3 SECTION = "console/network"
4 LICENSE = "GPL"
5 DEPENDS += "ncurses glib-2.0"
6 PR = "r3"
8 PACKAGES += "${PN}-common"
9 FILES_${PN} = "${bindir}/irssi"
10 FILES_${PN}-common = "${datadir}/irssi ${sysconfdir}"
11 RDEPENDS_${PN} += "${PN}-common"
13 inherit autotools
15 SRC_URI = "http://www.irssi.org/files/${P}.tar.bz2 \
16 file://autofoo.patch"
18 EXTRA_OECONF = "--enable-ipv6 \
19 --disable-ssl \
20 --disable-glibtest \
21 --without-socks \
22 --with-textui \
23 --without-bot \
24 --without-proxy \
25 --without-glib1 \
26 --with-glib2 \
27 --with-perl=no \
28 --with-glib-prefix=${STAGING_LIBDIR}/.. \
29 --with-glib-exec-prefix=${STAGING_LIBDIR}/.. \
30 --with-ncurses=${STAGING_LIBDIR}/.."
32 do_configure () {
33 # create help files
34 echo "Creating help files..."
35 perl syntax.pl
37 files=`echo docs/help/in/*.in|sed -e 's,docs/help/in/Makefile.in ,,' -e 's,docs/help/in/,!,g' -e 's/\.in /.in ?/g'`
38 cat docs/help/in/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/in/Makefile.am
40 files=`echo $files|sed 's/\.in//g'`
41 cat docs/help/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/Makefile.am
43 # .HTML -> .txt with lynx
44 # echo "Documentation: html -> txt..."
45 # lynx -dump -nolist docs/faq.html|perl -pe 's/^ *//; if ($_ eq "\n" && $state eq "Q") { $_ = ""; } elsif (/^([QA]):/) { $state = $1 } elsif ($_ ne "\n") { $_ = " $_"; };' > docs/faq.txt
46 > docs/faq.txt
48 autotools_do_configure
51 do_stage () {
52 find . -name \*.h | for h in `cat`; do
53 install -d ${STAGING_LIBDIR}/../irssi/`dirname $h`
54 install -m 0644 $h ${STAGING_LIBDIR}/../irssi/$h
55 done
56 find . -name lib\*.a | for l in `cat`; do
57 install -d ${STAGING_LIBDIR}/../irssi/`dirname $l`
58 install -m 0644 $l ${STAGING_LIBDIR}/../irssi/$l
59 done
60 install -m 0644 irssi-config ${STAGING_LIBDIR}/../irssi/
63 do_install () {
64 autotools_do_install
65 rm -f ${D}${docdir}/irssi/faq.txt
68 SRC_URI[md5sum] = "4b83d4047670eb75bd14ae1bdd68dc38"
69 SRC_URI[sha256sum] = "47344b444d78ad5965eb40cc4c8df8450fdc54135e2b058710ee8c500b958d6c"