checksums.ini: add checksum for pengutronix canutils
[openembedded.git] / packages / xorg-lib / libx11_git.bb
blobf2929624e8949a006a41a81c99b367a5f6dac567
1 DEFAULT_PREFERENCE = "-1"
3 DESCRIPTION = "Xlib/XCB: Xlib with XCB transport"
4 SECTION = "x11/libs"
5 LICENSE = "XFree86"
6 DEPENDS = "libxcb xproto xextproto libxau xtrans libxdmcp xcmiscproto xf86bigfontproto kbproto inputproto bigreqsproto util-macros"
7 PROVIDES = "virtual/libx11"
8 RPROVIDES = "virtual/libx11"
9 PR = "r1"
11 FILES_${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB"
12 FILES_${PN}-locale += "${datadir}/X11/locale"
14 SRC_URI = "git://anongit.freedesktop.org/git/xorg/lib/libX11;protocol=git"
15 S = "${WORKDIR}/git"
17 inherit autotools pkgconfig
19 EXTRA_OECONF="--enable-malloc0returnsnull"
21 do_compile() {
23 unset CC LD CXX CCLD
24 oe_runmake -C src/util 'CC=${BUILD_CC}' 'LD=${BUILD_LD}' 'CXX=${BUILD_CXX}' 'CCLD=${BUILD_CCLD}' 'CFLAGS=-D_GNU_SOURCE ${BUILD_CFLAGS}' 'LDFLAGS=${BUILD_LDFLAGS}' 'CXXFLAGS=${BUILD_CXXFLAGS}' 'CPPFLAGS=${BUILD_CPPFLAGS}' makekeys
26 oe_runmake
29 do_stage() {
30 autotools_stage_all