5 DEFAULT_PREFERENCE
= "-1"
7 PV
= "0.21+0.22rc+svnr${SRCREV}"
12 SRC_URI
= "svn://svn.mythtv.org/svn/trunk;module=mythtv;proto=http"
14 SRC_URI
+= "file://configure.patch;patch=1 \
17 S
= "${WORKDIR}/mythtv"
19 QMAKE_PROFILES
= "mythtv.pro"
21 mythlibs
= "mythdb mythavutil mythavcodec mythavformat myth mythtv mythui mythfreemheg mythupnp mythlivemedia"
22 PACKAGES
=+ "mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-data"
24 FILES_$
{PN
}-dbg
+= "${libdir}/mythtv/filters/.debug"
25 FILES_mythtv
-backend
= "${bindir}/mythbackend ${bindir}/mythcommflag ${bindir}/mythfilldatabase ${bindir}/mythtranscode"
26 FILES_mythtv
-frontend
= "${bindir}/mythfrontend ${datadir}/mythtv/i18n/mythfrontend_* ${datadir}/mythtv/*.ttf"
27 FILES_mythtv
-bin = "${bindir}/*"
28 FILES_mythtv
-filters
= "${libdir}/mythtv/filters/*"
29 FILES_mythtv
-data = "${datadir}"
30 RDEPENDS_$
{PN
} = "mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-data"
31 ALLOW_EMPTY_$
{PN
} = "1"
33 PACKAGES_DYNAMIC
= "mythtv-theme-*"
35 python __anonymous
() {
38 mythlibs
= bb.
data.getVar
('mythlibs'
, d
).split
()
39 pv
= bb.
data.expand
(bb.
data.getVar
("REALPV", d
), d
)
42 bb.
data.setVar
("FILES_lib%s%s" % (m
, pv
), "${libdir}/lib%s-%s.so.*" % (m
, pv
), d
)
43 bb.
data.setVar
("FILES_lib%s%s-dev" % (m
, pv
), "${libdir}/lib%s-%s.*" % (m
, pv
), d
)
45 packages
= " ".join
(map
(lambda x
: "lib%s%s lib%s%s-dev" % (x
, pv
, x
, pv
), mythlibs
) + bb.
data.getVar
("PACKAGES", d
).split
())
47 bb.
data.setVar
("PACKAGES", packages
, d
)
50 EXTRA_OECONF_armv5te
= " --enable-armv5te "
51 EXTRA_OECONF_armv6
= " --enable-armv6 "
52 EXTRA_OECONF_armv7a
= " --enable-armv6"
54 #build with support
for the iwmmxt instruction
and pxa270fb overlay support
(pxa270
and up
)
55 #
not every iwmmxt machine has the lcd connected
to pxafb
, but building the module doesn't hurt
56 MY_ARCH
:= "${PACKAGE_ARCH}"
57 PACKAGE_ARCH
= "${@base_contains('MACHINE_FEATURES', 'iwmmxt', 'iwmmxt', '${MY_ARCH}',d)}"
59 MY_TARGET_CC_ARCH
:= "${TARGET_CC_ARCH}"
60 TARGET_CC_ARCH
= "${@base_contains('MACHINE_FEATURES', 'iwmmxt', '-march=iwmmxt -mtune=iwmmxt', '${MY_TARGET_CC_ARCH}',d)}"
62 EXTRA_OECONF_append
= " ${@base_contains('MACHINE_FEATURES', 'iwmmxt', '--enable-pxa --enable-iwmmxt', '',d)} "
65 do_configure_prepend
() {
66 # it's
not autotools anyway
, so we call .
/configure directly
67 find .
-name
"Makefile"|xargs rm
-f
69 .
/configure
--prefix
=/usr \
71 --cpu
=$
{MYTHTV_ARCH
} \
72 --arch
=$
{MYTHTV_ARCH
} \
74 --disable
-opengl
-video \
82 --dvb
-path
=$
{STAGING_INCDIR
} \
86 sed 's
!PREFIX
=.
*!PREFIX
= $
{prefix
}!;/INCLUDEPATH += $${PREFIX}\/include/d' < settings.pro > settings.pro.new
87 mv settings.pro.
new settings.pro
88 for pro in $
{S
}/*/*pro $
{S
}/*/*/*pro $
{S
}/*/*/*/*pro
; do
89 sed
-i
-e s
:opengl
::g $pro
91 sed
-i
/.SUBDIR
/d $
{S
}/bindings
/*pro
94 python populate_packages_prepend
() {
97 def the_hook
(file
, pkg
, pattern
, format
, basename
):
98 new_packages.append
(pkg
)
100 do_split_packages
(d
, root
=bb.
data.expand
('$
{datadir
}/mythtv
/themes'
, d
), file_regex
='
(.
*)'
, output_pattern
='mythtv
-theme
-%s'
, description
='MythTV theme
%s'
, allow_dirs
=True, hook
=the_hook
, prepend
=True)
102 bb.
data.setVar
("RDEPENDS_${PN}", "%s %s" % (bb.
data.getVar
("RDEPENDS_${PN}", d
), " ".join
(new_packages
)), d
)