checksums.ini: add checksum for pengutronix canutils
[openembedded.git] / packages / gammu / gammu_1.20.0.bb
blob6cc864498a365c26f71070c5019772981bf6b88d
1 DESCRIPTION = "GNU All Mobile Managment Utilities"
2 SECTION = "console/network"
3 DEPENDS = "bluez-libs cmake-native"
4 LICENSE = "GPL"
5 HOMEPAGE = "http://www.gammu.org/"
6 PR = "r1"
8 SRC_URI = "http://dl.cihar.com/gammu/releases/gammu-${PV}.tar.bz2 "
10 # it is CMake based but when inherit cmake it builds static binary/library
11 inherit autotools pkgconfig
13 do_configure() {
14 cd ${S} && CMAKE_C_COMPILER=${TARGET_OS}-gcc ./configure --prefix=${prefix} --enable-shared --enable-backup
17 do_stage() {
18 autotools_stage_all
21 # gammu has a non-standard uninstalled .pc file, which confuses pkgconfig.bbclass.
22 # Replace it by custom do_stage_append():
23 do_stage_append () {
24 install -d ${PKG_CONFIG_DIR}
25 cat build-configure/cfg/gammu.pc > ${PKG_CONFIG_DIR}/gammu.pc
28 PACKAGES =+ "libgammu"
30 FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker"
31 FILES_${PN}-dev += "${bindir}/gammu-config"
32 FILES_libgammu = "${libdir}/libGammu.so.*"