checksums.ini: add checksum for pengutronix canutils
[openembedded.git] / packages / autofs / autofs_4.1.4.bb
blobd9863ad9dd68ced6ec74858ea4abb8c5ef37cdfe
1 DESCRIPTION = "Kernel based automounter for linux."
2 SECTION = "base"
3 LICENSE = "GPL"
5 PR = "r2"
7 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
8 ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
9 ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-multi-parse-fix.patch;patch=1 \
10 ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-non-replicated-ping.patch;patch=1 \
11 file://cross.patch;patch=1 \
12 file://Makefile.rules-cross.patch;patch=1 \
13 file://install.patch;patch=1 \
14 file://auto.net-sort-option-fix.patch;patch=1 \
15 file://autofs-additional-distros.patch;patch=1 \
16 file://no-bash.patch;patch=1"
18 inherit autotools update-rc.d
20 INITSCRIPT_NAME = "autofs"
21 INITSCRIPT_PARAMS = "defaults"
23 EXTRA_OEMAKE="TARGET_PREFIX=${TARGET_PREFIX}"
24 PARALLEL_MAKE = ""
26 do_configure_prepend () {
27 if [ ! -e acinclude.m4 ]; then
28 cp aclocal.m4 acinclude.m4
32 do_install () {
33 oe_runmake 'INSTALLROOT=${D}' install