1 DESCRIPTION
= "C-Kermit is a combined serial and network communication \
2 software package offering a consistent, medium-independent, \
3 cross-platform approach to connection establishment, terminal \
4 sessions, file transfer, character-set translation, and automation \
5 of communication tasks."
7 HOMEPAGE
= "http://www.columbia.edu/kermit/"
8 SECTION
= "console/network"
9 SRC_URI
= "ftp://kermit.columbia.edu/kermit/archives/cku${PV}.tar.gz"
13 # From http
://www.columbia.edu
/kermit
/ck80.html#license
15 #
"Free Unix Distributions: C-Kermit may be included in "free Unix
"
16 # distributions such as GNU/Linux, FreeBSD, NetBSD, and OpenBSD. See the
17 # license for details."
19 # A distributions based on OpenEmbedded
(OpenZaurus
, OpenSimpad etc
) is a
20 #
"free Unix" distribution
, therefore we can
include the package.
23 # Please note that the license is
not 100% because it limits what you can
26 #
"The C-Kermit source code may not be changed without the consent of
27 # the Kermit Project, which will not be unreasonably withheld (this is
28 # simply a matter of keeping a consistent and supportable code base)."
30 # But we don't change the source code in any way
, so we comply
to the license.
31 # So
, essentially
for us C
-Kermit is free as in beer
, but
not in freedom.
33 # That is
true for other distros. C
-Kkermit is distributed by
:
35 # Debian
: http
://packages.debian.org
/unstable
/comm
/ckermit
36 # Gentoo
: http
://mirror.pudas.net
/gentoo
-x86
-portage
/app
-misc
/ckermit
/ckermit
-8.0.211.ebuild
37 # SuSE
: http
://www.novell.com
/products
/linuxpackages
/enterpriseserver
/s390
/ckermit.html
38 # Fedora Core
: http
://cvs.fedora.redhat.com
/viewcvs
/devel
/ckermit
/
39 # PLD
: http
://cvs.pld.org.pl
/SPECS
/ckermit.spec
41 #
and, according
to the Kermit website http
://www.columbia.edu
/kermit
/ck80.html also with
43 # Red Hat
9 (on earlier Red Hat's it was on the PowerTools CD
)
49 # ...
and probably other distro's as well.
55 export BINDIR
= "${bindir}"
56 export MANDIR
= "${mandir}/man1"
57 export INFODIR
= "${infodir}"
59 # Additional flags.
For uclibc we add
-DNOARROWKEYS which stops ckermit
60 # trying
to look inside the stdio headers.
61 CKERMIT_ADDITIONAL
= ""
62 CKERMIT_ADDITIONAL_linux
-uclibc
= "-DNOARROWKEYS"
64 TARGET_CC_ARCH
+= "${LDFLAGS}"
67 # The original makefile doesn't differentiate between CC
and CC_FOR_BUILD
,
68 # so we build wart manually. Note that you need a ckwart.o with the proper
69 # timestamp
to make this hack work
:
70 $
{BUILD_CC
} -c ckwart.c
71 $
{BUILD_CC
} -o wart ckwart.o
72 .
/wart ckcpro.w ckcpro.c
74 #
read $
{S
}/ckccfg.txt
to understand this
:-)
75 oe_runmake wermit CFLAGS
="${CFLAGS} -DLINUX -DCK_POSIX_SIG \
76 -DNOTCPOPTS -DLINUXFSSTND -DNOCOTFMC -DPOSIX -DUSE_STRERROR \
77 -DNOSYSLOG -DHAVE_PTMX -DNO_DNS_SRV -DNOGFTIMER \
78 -DNOB_50 -DNOB_75 -DNOB_134 -DNOB_150 -DNOB_200 \
79 -DNOB_1800 -DNOB_3600 -DNOB_7200 -DNOB_76K -DNOB_230K \
80 -DNOB_460K -DNOB_921K \
81 -DNOAPC -DNOCSETS -DNONET -DNOUNICODE -DNOHELP -DNODEBUG \
82 -DNOFRILLS -DNOFTP -DNODIAL -DNOPUSH -DNOIKSD -DNOHTTP -DNOFLOAT \
83 -DNOSERVER -DNOSEXP -DNORLOGIN -DNOOLDMODEMS -DNOSSH -DNOLISTEN \
84 -DNORESEND -DNOAUTODL -DNOSTREAMING -DNOHINTS -DNOCKXYZ -DNOLEARN \
85 -DNOMKDIR -DNOPERMS -DNOCKTIMERS -DNOCKREGEX -DNOREALPATH \
86 -DCK_SMALL -DNOLOGDIAL -DNORENAME -DNOWHATAMI \
87 ${CKERMIT_ADDITIONAL}"
91 install
-d $
{D
}$
{BINDIR
} $
{D
}$
{MANDIR
} $
{D
}$
{INFODIR
}
92 oe_runmake 'DESTDIR
=$
{D
}' 'MANDIR
=$
{D
}$
{MANDIR
}' install
93 # Fix up dangling symlink
94 rm $
{D
}$
{BINDIR
}/kermit
-sshsub
95 (cd $
{D
}$
{BINDIR
} && ln
-s $
{BINDIR
}/kermit kermit
-sshusb
)
98 SRC_URI
[md5sum
] = "5767ec5e6ff0857cbfe2d3ec1ee0e2bc"
99 SRC_URI
[sha256sum
] = "39e7cd4892502344a635952843487d9b4bfa98e59d1e1acad5ef8aa969abba93"