gettext: move to BBCLASSEXTEND, taken from popky
[openembedded.git] / recipes / gettext / gettext_0.17.bb
blob2f8429cdaed2500ccbdee2b7d9e0291cddad5e71
1 DESCRIPTION = "The GNU internationalization library."
2 HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
3 SECTION = "libs"
4 LICENSE = "GPLv3"
5 PR = "r4"
6 DEPENDS = "gettext-native virtual/libiconv ncurses expat"
7 DEPENDS_virtclass-native = ""
8 PROVIDES = "virtual/libintl"
9 PROVIDES_virtclass-native = ""
12 SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
13 file://autotools.patch;patch=1 \
14 file://wchar-uclibc.patch;patch=1 \
15 file://use_open_properly.patch;patch=1 \
16 file://gettext-autoconf-lib-link-no-L.patch;patch=1 \
19 SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch;patch=1"
20 SRC_URI_append_linux-uclibceabi = " file://gettext-error_print_progname.patch;patch=1"
22 PARALLEL_MAKE = ""
24 inherit autotools
26 EXTRA_OECONF += "--without-lispdir \
27 --disable-csharp \
28 --disable-libasprintf \
29 --disable-java \
30 --disable-native-java \
31 --disable-openmp \
32 --with-included-glib \
33 --without-emacs \
36 acpaths = '-I ${S}/autoconf-lib-link/m4/ \
37 -I ${S}/gettext-runtime/m4 \
38 -I ${S}/gettext-tools/m4'
41 # these lack the .x behind the .so, but shouldn't be in the -dev package
42 # Otherwise you get the following results:
43 # 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
44 # 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
45 # because gettext depends on gettext-dev, which pulls in more -dev packages:
46 # 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
47 # 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
48 # 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
49 # 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
51 PACKAGES =+ "libgettextlib libgettextsrc"
52 FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
53 FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
55 BBCLASSEXTEND = "native nativesdk"