gettext: move to BBCLASSEXTEND, taken from popky
[openembedded.git] / recipes / gettext / gettext_0.14.1.bb
blob77ec7b9e4ee7650e5bc7387726e771ec2f57c0ab
1 DESCRIPTION = "The GNU internationalization library."
2 HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
3 SECTION = "libs"
4 LICENSE = "GPL"
5 PR = "r11"
6 DEPENDS = "virtual/libiconv"
7 DEPENDS_virtclass-native = ""
8 PROVIDES = "virtual/libintl"
9 PROVIDES_virtclass-native = ""
11 SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
12 file://gettext-vpath.patch;patch=1;pnum=1 \
13 file://fixchicken.patch;patch=1;pnum=1 \
14 file://linklib_from_0.17.patch;patch=1 \
15 file://gettext-autoconf-lib-link-no-L.patch;patch=1 \
16 file://getline.m4.patch;patch=1 \
17 file://disable_java.patch;patch=1"
19 SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch;patch=1"
20 SRC_URI_append_linux-uclibceabi = " file://gettext-error_print_progname.patch;patch=1"
22 PARALLEL_MAKE = ""
24 inherit autotools
26 EXTRA_OECONF += "--without-lisp --disable-csharp"
27 acpaths = '-I ${S}/autoconf-lib-link/m4/ \
28 -I ${S}/gettext-runtime/m4 \
29 -I ${S}/gettext-tools/m4'
31 do_configure_prepend() {
32 rm -f ${S}/config/m4/libtool.m4
35 # these lack the .x behind the .so, but shouldn't be in the -dev package
36 # Otherwise you get the following results:
37 # 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
38 # 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
39 # because gettext depends on gettext-dev, which pulls in more -dev packages:
40 # 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
41 # 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
42 # 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
43 # 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
45 PACKAGES =+ "libgettextlib libgettextsrc"
46 FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
47 FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"