xfsdump: Switch to getting libtool from PATH
[openembedded.git] / recipes / xfce-base / xfwm4_4.6.2.bb
blob3ea7f5281fc086d4caae29ca0f089a0899bd91b7
1 # xfwm4 OE build file
3 DESCRIPTION="Xfce4 Window Manager"
4 SECTION = "x11/wm"
5 PR = "r0"
7 inherit xfce46 update-alternatives
9 FILES_${PN} += "${datadir}/xfwm4/defaults ${datadir}/xfwm4/themes/default.keys/*"
11 DEPENDS = "startup-notification virtual/libx11 libxpm libxfce4util libxfcegui4"
12 RDEPENDS_${PN} = "xfwm4-theme-default"
14 EXTRA_OECONF += " --enable-startup-notification"
16 PACKAGES_DYNAMIC += "xfwm4-theme-*"
18 python populate_packages_prepend () {
19 themedir = bb.data.expand('${datadir}/themes', d)
20 do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
23 ALTERNATIVE_NAME = "x-window-manager"
24 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
25 ALTERNATIVE_PATH = "${bindir}/xfce4-session"
26 ALTERNATIVE_PRIORITY = "30"
28 FILES_${PN}-dbg += "${libexecdir}/xfce4/xfwm4/.debug/*"
30 SRC_URI[md5sum] = "3e6c0c54b028b6ea60e865e55ecdf3f8"
31 SRC_URI[sha256sum] = "212819ee03c24635f79d50930284c422469e22489952d0b286e6fe5af2155828"