xfsdump: Switch to getting libtool from PATH
[openembedded.git] / recipes / meta / openprotium-packages.bb
blobdacacd1562becca4d5c3083c47798cf36f819ba4
1 # Meta package containing all the packages which build for SlugOS
3 # All packages in here must build with the slugos-???.conf distros,
4 # they do not necessarily work.
5 DESCRIPTION = "Packages that are compatible with the Openprotium on the iomega Storcenter"
6 HOMEPAGE = "http://www.openprotium.org"
7 LICENSE = "MIT"
8 PR = "r5"
9 CONFLICTS = "db3"
10 PROVIDES += "${OPENPROTIUM_IMAGENAME}-packages"
12 EXCLUDE_FROM_WORLD = "1"
13 INHIBIT_DEFAULT_DEPS = "1"
14 ALLOW_EMPTY = "1"
16 inherit meta
18 # The list of packages to build for the slugos DISTRO.
19 # KEEP IN ALPHABETICAL ORDER
20 # Do *not* simply comment out a line. That will break. Instead
21 # remove the package and place it in the corresponding "broken" list
23 # deleted from "base" as they don't immediately build...
24 # asterisk \
25 # asterisk-sounds \
26 # beep \
27 # cherokee \
28 # cyrus-sasl \
29 # atftp \
30 # flac \
31 # gphoto2 \
32 # gdb \
33 # lirc \
34 # masqmail \
35 # wakelan \
36 # wireless-tools \
37 # wpa-supplicant \
38 # openldap \
39 # bluez-utils-nodbus \
40 # lcdproc \
41 # libxml2 \
42 # libdvb \
43 # madwifi-ng \
44 # motion \
45 # ftpd-topfield \
46 # eciadsl \
47 # netpbm \
48 # reiserfsprogs reiser4progs \
49 # libgphoto2 \
50 # python \
51 # mpd \
52 # memtester \
53 # puppy \
54 # samba \
55 # sane-backends \
56 # vsftpd \
57 # syslog-ng \
58 # zd1211 \
59 # cdparanoia \
60 # litestream \
61 # pvrusb2-mci \
62 # pwc \
63 # fetchmail \
65 OPENPROTIUM_PACKAGES = "\
66 alsa-lib \
67 alsa-utils \
68 apache2 \
69 audiofile \
70 aumix \
71 autoconf \
72 automake \
73 bash \
74 bind \
75 binutils \
76 bison \
77 bridge-utils \
78 bzip2 \
79 ccxstream \
80 cdstatus \
81 coreutils \
82 cron \
83 ctorrent \
84 cvs \
85 db \
86 devlabel \
87 diffstat \
88 diffutils \
89 dnsmasq \
90 e2fsprogs \
91 e2fsprogs-libs \
92 expat \
93 ez-ipupdate \
94 file \
95 findutils \
96 flex \
97 flite \
98 gallery \
99 gawk \
100 gcc \
101 gdbm \
102 glib-2.0 \
103 gnu-config \
104 grep \
105 gtk-doc \
106 gzip \
107 hdparm \
108 ifupdown \
109 ipkg-utils \
110 iptables \
111 ircp \
112 joe \
113 jpeg \
114 libao \
115 libid3tag \
116 liblockfile \
117 libmad \
118 libmikmod \
119 libogg \
120 libol \
121 libpng \
122 libtool \
123 libupnp \
124 libusb \
125 libvorbis \
126 lrzsz \
127 lsof \
128 lvm2 \
129 m4 \
130 madplay \
131 mailx \
132 make \
133 mdadm \
134 mgetty \
135 miau \
136 microcom \
137 minicom \
138 modphp \
139 mt-daapd \
140 mtd-utils \
141 mutt \
142 nail \
143 nano \
144 ncftp \
145 ncurses \
146 netcat \
147 nmap \
148 ntp \
149 openobex-apps \
150 openntpd \
151 openobex \
152 openssh \
153 openvpn \
154 patch \
155 pciutils \
156 libpcre \
157 perl \
158 pkgconfig \
159 ppp \
160 procps \
161 quilt \
162 rng-tools \
163 rsync \
164 sed \
165 setpwc \
166 setserial \
167 smartmontools \
168 ssmtp \
169 strace \
170 streamripper \
171 sysfsutils \
172 tar \
173 thttpd \
174 tiff \
175 unzip \
176 usbutils \
177 util-linux \
178 vim \
179 vlan \
180 wget \
181 zip \
182 zlib \
185 # Packages currently broken on all platforms
186 SLUGOS_BROKEN_PACKAGES = "\
187 irssi \
188 obexftp \
189 qc-usb-messenger \
190 unionfs-modules \
191 unionfs-utils \
192 icecast \
193 cyrus-imapd \
196 # These packages will never build because uclibc lacks (and always will lack)
197 # appropriate support. This define is for documentation of this fact! The
198 # normal cause is that the package uses the "NIS" interfaces (once known as
199 # YP - a trademark of BT which SUN used without license - the missing function
200 # calls often still have 'yp' in the name).
202 # NOTE: rng-tools is only here until argp-standalone can be built!
203 UCLIBC_UNSUPPORTABLE_PACKAGES = "\
204 libpam \
205 nfs-utils \
206 rng-tools \
207 postfix \
208 yp-tools ypbind ypserv \
211 # These packages work with glibc, but break on uclibc.
212 UCLIBC_BROKEN_PACKAGES = "\
213 apr \
214 bogofilter \
215 boost \
216 bwmon \
217 erlang \
218 linphone \
219 sudo \
220 ushare \
223 # Packages which build only with glibc (some of these use internal
224 # glibc functions and so will probably never run on uclibc).
225 SLUGOS_PACKAGES_append_linux = "\
226 ${UCLIBC_UNSUPPORTABLE_PACKAGES} \
227 ${UCLIBC_BROKEN_PACKAGES} \
228 ctrlproxy \
229 dsniff \
230 iperf \
231 groff \
232 man man-pages \
233 psmisc \
234 screen \
235 tzdata \
236 wview-sim wview-vpro wview-wxt510 \
237 wview-sim-mysql wview-vpro-mysql \
238 wview-wxt510-mysql \
239 xinetd \
242 SLUGOS_PACKAGES_append_linux-uclibc = "\
245 # These packages are not in the build because they have a significant compilation
246 # time, add them to SLUGOS_EXTRA_PACKAGES if required
247 SLUGOS_OPTIONAL_PACKAGES = "\
248 mysql \
252 # you can place these in the top level openembedded/conf/distro/openprotium.conf
253 # file to fine-tune what's happening
255 OPENPROTIUM_EXTRA_PACKAGES ?= ""
257 # The package-index at the end causes regeneration of the Packages.gz and
258 # other control files.
259 # openprotium-native \
260 DEPENDS = "\
261 openprotium-image \
262 ${OPENPROTIUM_PACKAGES} \
263 ${OPENPROTIUM_EXTRA_PACKAGES} \
264 package-index \