db_5.0.21: Add recipes for target and native packages.
[openembedded.git] / recipes / efl1 / libeweather_svn.bb
blob30039c007812ef79675396cba6ccbe60ec3d9211
1 DESCRIPTION = "EFL-based weather widget library"
2 LICENSE = "LGPL"
3 DEPENDS = "ecore edje"
4 PV = "0.0.0+svnr${SRCPV}"
5 PR = "r0"
6 SRCREV = "${EFL_SRCREV}"
8 inherit efl
10 EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
12 SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/PROTO;module=libeweather;proto=http"
13 S = "${WORKDIR}/eweather"
15 RSUGGESTS_${PN} = "elementary-tests"
17 do_compile_append() {
18 sed -i -e s:${STAGING_DIR_TARGET}::g \
19 -e s:/${TARGET_SYS}::g \
20 eweather.pc
23 PACKAGES += "${PN}-plugins"
25 FILES_${PN}-themes = "\
26 ${datadir} \
29 FILES_${PN}-plugins = "\
30 ${libdir}/eweather/plugins/*.so \
33 FILES_${PN}-dbg += "\
34 ${libdir}/eweather/plugins/.debug \
37 FILES_${PN}-dev += "\
38 ${libdir}/eweather/plugins/*.a \
39 ${libdir}/eweather/plugins/*.la \
42 RRECOMMENDS_${PN} = "\
43 ${PN}-themes \
44 ${PN}-plugins \