ti-dspbios: Add Latest Versions (5.41.08/08)
[openembedded.git] / recipes / sysconf / sysconf_0.1.bb
blobff6f025818a97a0701f1e3065b91bf4c6b9a51c9
1 DESCRIPTION = "System Configuration save/restore functionality"
2 SECTION = "base"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 RDEPENDS_${PN} = "devio cpio findutils diffutils"
6 PR = "r11"
8 # Currently, the scripts only support ixp4xx machines.
9 # Feel free to add to the scripts ...
10 COMPATIBLE_MACHINE = '(ixp4xx|nslu2)'
12 SRC_URI = "file://sysconfsetup \
13 file://conffiles \
14 file://sysconf \
17 SCRIPTS = "sysconf"
18 INITSCRIPTS = "sysconfsetup"
20 # This just makes things easier...
21 S="${WORKDIR}"
23 do_install() {
24 # Directories
25 install -d ${D}${sysconfdir} \
26 ${D}${sysconfdir}/default \
27 ${D}${sysconfdir}/init.d \
28 ${D}${base_sbindir}
30 # Init scripts
31 install -m 0755 sysconfsetup ${D}${sysconfdir}/init.d/
33 # Configuration files
34 install -m 0644 conffiles ${D}${sysconfdir}/default
36 # Shell scripts
37 install -m 0755 sysconf ${D}${base_sbindir}/sysconf
40 pkg_postinst() {
41 opt=
42 test -n "$D" && opt="-r $D"
43 update-rc.d $opt sysconfsetup start 12 S .
46 pkg_postrm() {
47 opt=
48 test -n "$D" && opt="-r $D"
49 update-rc.d $opt sysconfsetup remove