ti-dspbios: Add Latest Versions (5.41.08/08)
[openembedded.git] / recipes / linux / linux-wrt_2.4.30.bb
blob40171c1603d8bbf998fb3d0077c314dd0cf9bc93
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for the Linksys WRT54 devices"
3 HOMEPAGE = "http://openwrt.org"
4 DEPENDS = "lzma-native"
5 LICENSE = "GPLv2"
6 PR = "r2"
8 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-2.4.30.tar.bz2;name=kernel \
9 cvs://anonymous@openwrt.org/openwrt;module=openwrt/package/linux/kernel-source;tag=TESTED \
10 http://downloads.openwrt.org/sources/kernel-binary-wl-0.2.tar.gz;name=wlpatch \
11 http://downloads.openwrt.org/sources/kernel-source-et-0.6.tar.gz;name=etpatch \
12 file://000-linux-mips-2_4_30.patch \
13 file://001-Makefile;apply=yes \
14 file://002-Rules_make;apply=yes \
15 file://003-arch_mips_Makefile;apply=yes \
16 file://005-arch_mips_config-shared_in;apply=yes \
17 file://007-arch_mips_kernel_cpu-probe_c;apply=yes \
18 file://009-arch_mips_kernel_head_S;apply=yes \
19 file://010-arch_mips_kernel_proc_c;apply=yes \
20 file://011-arch_mips_kernel_setup_c;apply=yes \
21 file://012-arch_mips_kernel_traps_c;apply=yes \
22 file://017-arch_mips_pci_Makefile;apply=yes \
23 file://018_drivers_char_mem_c;apply=yes \
24 file://019-drivers_char_serial_c;apply=yes \
25 file://020-drivers_mtd-jumbo;apply=yes \
26 file://021-drivers_net_Config_in-hnd;apply=yes \
27 file://022-drivers_net_Makefile;apply=yes \
28 file://023-drivers_parport_Makefile;apply=yes \
29 file://024-drivers_parport_Config_in;apply=yes \
30 file://028-drivers_pcmcia_Makefile;apply=yes \
31 file://029-arch_mips_mm_c-r4k_c;apply=yes \
32 file://031-include_asm-mips_bootinfo_h;apply=yes \
33 file://033-include_asm-mips_cpu_h;apply=yes \
34 file://036-include_asm-mips_serial_h;apply=yes \
35 file://037-init_do_mounts_c;apply=yes \
36 file://100-gcc3-mtune;apply=yes \
37 file://200-include_linux_netdevice_h.patch \
38 file://201-include_linux_skbuff_h.patch \
39 file://202-net_core_Makefile.patch \
40 file://203-net_core_dev_c.patch \
41 file://204-net_sched_sched_api_c.patch \
42 file://205-net_sched_sched_generic_c.patch \
43 file://206-include_net_pkt_sched_h.patch \
44 file://207-hfsplus-fix;apply=yes \
45 file://208-gcc-3.4-fix;apply=yes \
46 file://300-squashfs2.1;apply=yes \
47 file://301-jffs-compression;apply=yes \
48 file://302-ebtables;apply=yes \
49 file://303-mppe-mppc;apply=yes \
50 file://304-netfilter-ipp2p-0.7.4;apply=yes \
51 file://305-cifs-1.20c;apply=yes \
52 file://306-netfilter-layer7-0.9.1;apply=yes \
53 file://307-gcc-3.4-fix.patch \
54 file://308-netfilter-nat-pptp;apply=yes \
55 file://309-drivers_net_b44_c.patch \
56 file://310-netfilter-maxconn;apply=yes \
57 file://311-ipsec-nat-traversal;apply=yes \
58 file://312-netfilter-TTL;apply=yes \
59 file://313-gcc-4.0-fixes;apply=yes \
60 file://314-drivers_net_b44_h.patch \
61 file://315-include_linux_pci_ids_h.patch \
62 file://316-b44_mii_phy.patch \
63 file://400-i4l-cvs-2-4-29;apply=yes \
64 file://401-hfc-usb-backport-i4l-cvs;apply=yes \
65 file://402-pl2303-backport-2-4-29;apply=yes \
66 file://403-netdev_random_core.patch \
67 file://404-netdev_random_et.patch \
68 file://600-linux-squashfs-lzma;apply=yes \
69 file://600-optional-aout-support;apply=yes \
70 file://linux.config"
72 S = "${WORKDIR}/linux-2.4.30"
74 COMPATIBLE_HOST = 'mipsel.*-linux'
76 inherit kernel
78 KERNEL_OUTPUT = "arch/mips/brcm-boards/bcm947xx/compressed/piggy"
79 CMDLINE = "root=/dev/mtdblock2 rootfstype=squashfs,jffs2 console=ttyS0,115200"
81 KERNEL_OBJECT_SUFFIX = ".o" ### should be auto
83 export CFLAGS_KERNEL="-fno-delayed-branch "
85 do_unpack_extra(){
86 # copy kernel source which is maintained in openwrt via cvs
87 cp -pPR ${WORKDIR}/kernel-source/* ${S}
88 # copy binary wlan driver
89 cp -pPR ${WORKDIR}/wl/*.o ${S}/drivers/net/wl
90 # copy proprietary et source
91 cp -pPR ${WORKDIR}/et/* ${S}/drivers/net/et
92 cp -pPR ${WORKDIR}/et/*.h ${S}/include/
94 addtask unpack_extra after do_unpack before do_patch
96 do_configure_prepend() {
97 install -m 0644 ${WORKDIR}/linux.config ${S}/.config
98 echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
100 sed -i -e 's/@expr length/@-expr length/' ${S}/Makefile
101 sed -i -e "s,\-mcpu=,\-mtune=,g;" ${S}/arch/mips/Makefile
104 do_deploy() {
105 install -d ${DEPLOY_DIR_IMAGE}
106 cat ${KERNEL_OUTPUT} | lzma e -si -so -eos > \
107 ${DEPLOY_DIR_IMAGE}/wrt-kernel-${PV}.lzma
110 COMPATIBLE_MACHINE = "wrt54"