linux-omap 2.6.37: replace various patch with upstream versions and rediff
[openembedded.git] / recipes / linux / linux_2.6.27.bb
blobfdcd8b7885740d2df6ce970e90afe389400cfc01
1 require linux.inc
3 PR = "r14"
5 # Mark archs/machines that this kernel supports
6 DEFAULT_PREFERENCE = "-1"
7 DEFAULT_PREFERENCE_boc01 = "1"
8 DEFAULT_PREFERENCE_progear = "1"
9 DEFAULT_PREFERENCE_simpad = "-1"
10 DEFAULT_PREFERENCE_ts72xx = "-1"
12 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
13 ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.45.bz2;apply=yes;name=stablepatch \
14 file://defconfig "
16 SRC_URI_append_boc01 = "\
17 file://boc01.dts \
18 file://001-090114-sqn11x0-usb-hack.patch \
19 file://004-081205-usb.patch \
20 file://005-090226-isl12024.patch \
21 file://007-081217-lm73.patch \
22 file://008-081208-spi.patch \
23 file://011-090115-gpio.patch \
24 file://012-090219-capsense.patch \
25 file://013-090306-lcd.patch \
28 SRC_URI_append_progear = "file://progear-bl.patch\
29 file://progear-ac2.patch"
31 SRC_URI_append_simpad = "\
32 file://linux-2.6.27-SIMpad-GPIO-MMC-mod.patch \
33 file://linux-2.6.27-SIMpad-battery-old-way-but-also-with-sysfs.patch \
34 file://linux-2.6.27-SIMpad-cs3-simpad.patch \
35 file://linux-2.6.27-SIMpad-mq200.patch \
36 file://linux-2.6.27-SIMpad-pcmcia.patch \
37 file://linux-2.6.27-SIMpad-serial-gpio_keys-and-cs3-ro.patch.v2;apply=yes \
38 file://linux-2.6.27-SIMpad-ucb1x00-switches.patch \
39 file://linux-2.6.27-SIMpad-ucb1x00-ts-supend-and-accuracy.patch \
40 file://linux-2.6.24-SIMpad-hostap_cs-shared-irq.patch \
41 file://linux-2.6.24-SIMpad-orinoco_cs-shared-irq.patch \
42 file://linux-2.6.24-SIMpad-rtc-sa1100.patch \
43 file://connectplus-remove-ide-HACK.patch \
46 SRC_URI_append_ts72xx = "\
47 file://0001-TS72xx-update-memory-map-comments.patch \
48 file://0002-GPIO-fix.patch \
49 file://0003-Debounce-IRQ.patch \
50 file://0004-OHCI-fix.patch \
51 file://0005-Fix-wrong-machine-ID-passed-from-RedBoot.patch \
52 file://0006-Force-the-nF-bit-on.patch \
53 file://0007-Use-CPLD-watchdog-to-reset.patch \
54 file://0008-Fix-UART-clocks.patch \
55 file://0009-CPU-info-and-board-revision.patch \
56 file://0010-GPIO-leds.patch \
57 file://0011-EP93xx-Ethernet-support.patch \
58 file://0012-TS72xx-watchdog.patch \
59 file://0013-TS7200-NOR-physmap-fix.patch \
60 file://0014-TS-7200-8MB-NOR-flash.patch \
61 file://0015-TS-72xx-MAX197-support.patch \
62 file://0016-RS485-common-bits.patch \
63 file://0017-TS-72xx-SBC-proc-info.patch \
64 file://0018-EP93xx-GPIO-I2C.patch \
65 file://0019-EP93xx-SPI-driver.patch \
66 file://0020-TS-72XX-LCD-console-driver.patch \
67 file://0021-EP93xx-GPIO-matrix-keypad.patch \
68 file://0022-TS-72xx-RS485-auto-mode-support.patch \
69 file://0023-Clean-and-invalidate-D-cache-entry.patch \
70 file://0024-PC-104-I-O-and-memory-mappings.patch \
71 file://0025-EP93xx-discontigmem.patch \
72 file://0026-TS72xx-PATA-support.patch \
73 file://0027-TS72xx-TS-SER1-support.patch \
74 file://0028-TS72xx-TS-ETH100.patch \
75 file://0029-EP93xx-Power-Management-Routines.patch \
76 file://0030-EP93xx-CPUfreq-driver.patch \
79 # see http://bugzilla.kernel.org/show_bug.cgi?id=11143
80 do_install_append() {
81 if [ -f arch/${ARCH}/lib/crtsavres.o ]; then
82 mkdir -p $kerneldir/arch/${ARCH}/lib
83 cp -a arch/${ARCH}/lib/crtsavres.o $kerneldir/arch/${ARCH}/lib/
88 SRC_URI[kernel.md5sum] = "b3e78977aa79d3754cb7f8143d7ddabd"
89 SRC_URI[kernel.sha256sum] = "0e99bf9e83f4d1ae0c656741a84dfddfa9c4d2469cf35475f5939d02dc3e4393"
90 SRC_URI[stablepatch.md5sum] = "9ad766753f54ba0a4df7c42873e7aa16"
91 SRC_URI[stablepatch.sha256sum] = "fb78c95e902194ac62facdbad1a89430c991271a35e4bd30ce9dad2f948d99c8"