1 DESCRIPTION
= "Linux Kernel for the IOMega StorCenter"
7 COMPATIBLE_MACHINE
= "storcenter"
9 SRC_URI
= "http://kernel.org/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
10 file://fw-and-powerpc-install.patch \
11 file://defconfig-${PV} \
14 S
= "${WORKDIR}/linux-${PV}"
20 KERNEL_IMAGETYPE
= "uImage"
22 FILES_kernel
-image
+= "/boot/storcenter.dtb"
25 mkdir
-p $
{IMAGE_ROOTFS
}
26 install
-m
0644 $
{WORKDIR
}/defconfig
-$
{PV
} $
{S
}/.config
27 ARCH
=$
{ARCH
} oe_runmake oldconfig
31 rm
-f $
{D
}/boot
/vmlinux
-*
32 dtc
-f
-I dts
-O dtb
-o $
{D
}/boot
/storcenter.dtb
-V
16 $
{S
}/arch
/$
{ARCH
}/boot
/dts
/storcenter.dts
35 do_builtin_initramfs_foonas
() {
39 pkg_preinst_foonas
() {
40 if [ "x$D" != "x" ]; then
41 ln
-sf $
{KERNEL_IMAGETYPE
}-$
{PV
} $
{D
}/boot
/uImage
46 ln
-sf $
{KERNEL_IMAGETYPE
}-$
{PV
} /boot
/uImage
50 install
-d $
{DEPLOY_DIR_IMAGE
}
51 install
-m
0644 $
{S
}/arch
/$
{ARCH
}/boot
/$
{KERNEL_IMAGETYPE
} $
{DEPLOY_DIR_IMAGE
}/vmlinux.UBoot
52 install
-m
0644 $
{D
}/boot
/storcenter.dtb $
{DEPLOY_DIR_IMAGE
}/storcenter.dtb
55 do_deploy
[dirs
] = "${S}"
57 addtask deploy
before do_package
after do_install
59 SRC_URI
[kernel.md5sum
] = "db323884c7dc46e4cd33d0d944fa59a9"
60 SRC_URI
[kernel.sha256sum
] = "8e7075fc855ffbcf3c24cbd70b22791759224f98839886d50bba8d659193a950"