linux-omap 2.6.37: replace various patch with upstream versions and rediff
[openembedded.git] / recipes / linux / linux-jlime-ben-nanonote_2.6.36.bb
blobad59e5154d9e33150fe9186de401a7cd1846ce60
1 DESCRIPTION = "Linux 2.6.36 kernel for the Ben Nanonote"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
5 DEPENDS += "u-boot-mkimage-native"
7 SRCREV = "${AUTOREV}"
9 DEFAULT_PREFERENCE_ben-nanonote = "1"
10 COMPATIBLE_MACHINE = "ben-nanonote"
12 KERNEL_IMAGETYPE = "vmlinux.bin"
14 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kristoffer/linux-hpc.git;protocol=git;branch=v2.6.36-hpc \
15 file://logo_linux_clut224.tar.gz \
16 file://modifier-keys.patch"
18 S = "${WORKDIR}/git"
20 inherit kernel
22 FILES_kernel-image = "/boot/uImage*"
24 do_configure_prepend() {
25 install -m 0644 ${S}/config-ben-nanonote ${S}/.config
26 mv -f ${WORKDIR}/logo_linux_clut224.ppm ${S}/drivers/video/logo
29 do_install_append() {
30 cd ${S}
31 kernel_entry=`nm vmlinux | grep " kernel_entry" | cut -d' ' -f1`
33 cd ${S}/arch/mips/boot
34 rm -f vmlinux.bin.gz
35 gzip -c9 vmlinux.bin > vmlinux.bin.gz
37 mkimage -A mips -O linux -T kernel -C gzip -a 0x80010000 -e 0x${kernel_entry} \
38 -n 'MIPS' -d vmlinux.bin.gz uImage-${KERNEL_VERSION}
40 install -m 0644 uImage-${KERNEL_VERSION} ${D}/boot
43 pkg_postinst_kernel() {
44 cd /${KERNEL_IMAGEDEST}; update-alternatives --install /${KERNEL_IMAGEDEST}/uImage uImage uImage-${KERNEL_VERSION} ${KERNEL_PRIORITY} || true
47 pkg_postrm_kernel() {
48 cd /${KERNEL_IMAGEDEST}; update-alternatives --remove uImage uImage-${KERNEL_VERSION} || true