linux-omap 2.6.37: replace various patch with upstream versions and rediff
[openembedded.git] / recipes / linux / linux-dht-walnut_2.6.23.bb
blobfee1ff9cab6edd5514a9cb4498f39171402221ee
1 # Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
2 # Released under the MIT license (see packages/COPYING)
3 require linux.inc
5 DESCRIPTION = "Linux kernel for DHT-Walnut (ppc) machine"
7 DEFAULT_PREFERENCE = "-1"
9 PR = "r0"
10 DEPENDS = "u-boot"
12 COMPATIBLE_MACHINE = "dht-walnut"
14 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
15 file://defconfig"
17 S = "${WORKDIR}/linux-${PV}"
19 FILES_kernel-image = "/boot/zImage.elf"
21 export OS = "Linux"
22 ARCH = "ppc"
24 do_install_append () {
25 #need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
27 install -d $kerneldir/arch/
28 cp -pPR arch/ppc $kerneldir/arch/
29 cp -pPR arch/powerpc $kerneldir/arch/
31 cp -pPR include/asm-powerpc $kerneldir/include/
32 cp -pPR include/asm-ppc $kerneldir/include/
35 do_install_append () {
36 install -d ${DEPLOY_DIR_IMAGE}
37 if [ -e arch/ppc/boot/images/zImage.elf ] ; then
38 cp -a arch/ppc/boot/images/zImage.elf arch/ppc/boot/images/zImage
39 install -m 0755 arch/ppc/boot/images/zImage.elf \
40 ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.elf
41 fi
42 install -m 0755 vmlinux ${DEPLOY_DIR_IMAGE}/
46 pkg_postinst_kernel () {
47 true
50 pkg_postrm_kernel () {
51 true
58 SRC_URI[md5sum] = "2cc2fd4d521dc5d7cfce0d8a9d1b3472"
59 SRC_URI[sha256sum] = "d4e67c0935ffb2a4158234bff92cc791b83177866009fc9b2214104e0038dbdb"