linux-omap 2.6.37: replace various patch with upstream versions and rediff
[openembedded.git] / recipes / linux / devkitidp-pxa255_2.6.19.bb
bloba747cfad2d0b6f032e7847ddff60d1ce9f52fb40
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for the BSQUARE PXA255 DevKitIDP"
3 LICENSE = "GPLv2"
4 PR = "r4"
5 DEPENDS = "u-boot"
7 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.19.tar.bz2 \
8 file://linux-2.6.19_devkitidp1.patch \
9 file://defconfig"
11 S = "${WORKDIR}/linux-2.6.19"
13 COMPATIBLE_MACHINE = "devkitidp-pxa255"
15 inherit kernel
16 inherit package
18 ARCH = "arm"
19 KERNEL_IMAGETYPE = "uImage"
20 #CMDLINE_CONSOLE ?= "ttyS0,115200n8"
21 #CMDLINE_ROOT = "root=/dev/slug rootfstype=ext2,jffs2 initrd=0x01000000,10M mem=32M@0x00000000"
22 #CMDLINE_ROOT = "root=/dev/mtdblock4 rootfstype=jffs2 mem=32M@0x00000000"
23 #CMDLINE_ROOT = "root=/dev/ram0 rw rootfstype=ext2,jffs2 initrd=0x01000000,10M init=/linuxrc mem=32M@0x00000000"
24 #CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE}"
25 CMDLINE = "root=/dev/mtdblock2 rootfstype=jffs2 console=ttyS0,115200 mtdparts=phys_mapped_flash:256k(boot)ro,0x1C0000(kernel),-(root)"
27 do_configure_prepend() {
28 install -m 0644 ${WORKDIR}/defconfig ${S}/.config
29 # echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
32 SRC_URI[md5sum] = "443c265b57e87eadc0c677c3acc37e20"
33 SRC_URI[sha256sum] = "c2fd6bcd2b7c1b3d37d64e4d1825703792a75474830a3db7d2dc603a8d392d58"