u-boot git: update beagleboard patches
[openembedded.git] / recipes / vim / vim_7.2.bb
blobb1d71a22b4c23cc8609814e76110c7eb204f2055
1 VIMVER = "72"
3 # vim-tiny sets that too
4 VIMFEATURES ?= "big"
6 # GUI type - gvim recipe sets "gtk2"
7 VIMGUI ?= "none"
9 # gvim recipes uses "--with-x"
10 VIMX ?= "--without-x"
12 require vim.inc
14 PR = "${INC_PR}.1"
16 # 001-411.diff contains 411 patches fetched from upstream
17 SRC_URI += "file://001-411.diff"
19 # we need to apply patches in other dir then ${S}
20 do_applypatch() {
21 cd ${WORKDIR}/vim${VIMVER}
22 patch -p1 <${WORKDIR}/001-411.diff
25 addtask applypatch after do_unpack before do_patch
27 RCONFLICTS_${PN} = "gvim vim-tiny"