u-boot git: update beagleboard patches
[openembedded.git] / recipes / meta / foonas-packages.bb
blob2bd8437f1378cd3cb949d491f5649d62570a1884
1 DESCRIPTION = "Packages that are compatible with FooNAS"
2 LICENSE = "MIT"
3 PR = "r2"
4 CONFLICTS = "db3"
5 PROVIDES += "${FOONAS_IMAGENAME}-packages"
7 EXCLUDE_FROM_WORLD = "1"
8 INHIBIT_DEFAULT_DEPS = "1"
9 ALLOW_EMPTY = "1"
11 inherit meta
13 FOONAS_PACKAGES = "\
14 adns \
15 alsa-lib \
16 alsa-utils \
17 apache2 \
18 asterisk \
19 audiofile \
20 aumix \
21 autoconf \
22 automake \
23 bash \
24 bash-completion \
25 bc \
26 beep \
27 bind \
28 binutils \
29 bison \
30 bridge-utils \
31 bonnie++ \
32 bzflag \
33 bzip2 \
34 ccxstream \
35 cdparanoia \
36 cdstatus \
37 cherokee \
38 chillispot \
39 coreutils \
40 cpusage \
41 cpuspeed \
42 cron \
43 ctorrent \
44 cvs \
45 dash \
46 db \
47 dbench \
48 devlabel \
49 dhcpcd \
50 dialog \
51 diffstat \
52 diffutils \
53 dircproxy \
54 dnsmasq \
55 dosfstools \
56 e2fsprogs \
57 e2fsprogs-libs \
58 e2tools \
59 eb \
60 ebtables \
61 elvis \
62 expat \
63 ez-ipupdate \
64 fetchmail \
65 file \
66 findutils \
67 flex \
68 flite \
69 gawk \
70 gcc \
71 gdbm \
72 gnu-config \
73 grep \
74 gtk-doc \
75 gzip \
76 hdparm \
77 ipkg-utils \
78 iptables \
79 ircp \
80 joe \
81 jpeg \
82 less \
83 libao \
84 libid3tag \
85 liblockfile \
86 libmad \
87 libmikmod \
88 libogg \
89 libol \
90 libpng \
91 libtool \
92 libupnp \
93 libusb \
94 libvorbis \
95 litestream \
96 lrzsz \
97 lsof \
98 lvm2 \
99 m4 \
100 madplay \
101 mailx \
102 make \
103 mdadm \
104 mgetty \
105 miau \
106 microcom \
107 minicom \
108 modphp \
109 mt-daapd \
110 mtd-utils \
111 mutt \
112 nail \
113 nano \
114 ncftp \
115 ncurses \
116 netcat \
117 nmap \
118 ntp \
119 openobex-apps \
120 openldap \
121 openntpd \
122 openobex \
123 openssh \
124 openvpn \
125 patch \
126 pciutils \
127 libpcre \
128 perl \
129 pkgconfig \
130 postgresql \
131 ppp \
132 procps \
133 quilt \
134 rng-tools \
135 rsync \
136 sed \
137 setserial \
138 smartmontools \
139 ssmtp \
140 strace \
141 streamripper \
142 sysfsutils \
143 syslog-ng \
144 tar \
145 thttpd \
146 tzdata \
147 tiff \
148 unzip \
149 usbutils \
150 util-linux \
151 vim \
152 vlan \
153 watchdog \
154 wget \
155 wireless-tools \
156 zip \
157 zlib \
160 FOONAS_EXTRA_PACKAGES ?= ""
162 # The package-index at the end causes regeneration of the Packages.gz and
163 # other control files.
164 DEPENDS = "\
165 foonas-image \
166 ${FOONAS_PACKAGES} \
167 ${FOONAS_EXTRA_PACKAGES} \
168 package-index \