nfs-utils : Fix support for util-linux-ng. See bug #4459.
[openembedded.git] / packages / nfs-utils / nfs-utils_1.1.2.bb
blobbcdabd59e5d7647307e769ed72344f78a1aab90b
1 DESCRIPTION = "userspace utilities for kernel nfs"
2 PRIORITY = "optional"
3 SECTION = "console/network"
4 LICENSE = "GPL"
6 PR = "2"
8 DEPENDS = "tcp-wrappers libevent"
10 SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
11 file://nfsserver \
14 S = "${WORKDIR}/nfs-utils-${PV}/"
16 PARALLEL_MAKE = ""
18 # Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
19 # pull in the remainder of the dependencies.
20 RDEPENDS = "portmap"
21 RRECOMMENDS = "kernel-module-nfsd"
23 INITSCRIPT_NAME = "nfsserver"
24 # The server has no dependencies at the user run levels, so just put
25 # it in at the default levels. It must be terminated before the network
26 # in the shutdown levels, but that works fine.
27 INITSCRIPT_PARAMS = "defaults"
29 inherit autotools update-rc.d
31 EXTRA_OECONF = "--with-statduser=nobody \
32 --enable-nfsv3 \
33 --disable-nfsv4 \
34 --disable-gss \
35 --with-statedir=/var/lib/nfs"
37 do_ccompile() {
38 # UGLY HACK ALERT
39 cat ${WORKDIR}/forgotten-defines >> ${S}/support/include/config.h
40 oe_runmake 'BUILD=1'
43 INHIBIT_AUTO_STAGE = "1"
45 do_install() {
46 install -d ${D}${sysconfdir}/init.d
47 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
49 install -d ${D}${sbindir}
50 install -d ${D}${base_sbindir}
51 install -m 0755 ${S}/utils/exportfs/exportfs ${D}${sbindir}/exportfs
52 install -m 0755 ${S}/utils/mountd/mountd ${D}${sbindir}/mountd
53 install -m 0755 ${S}/utils/mount/mount.nfs ${D}${base_sbindir}/mount.nfs
54 install -m 0755 ${S}/utils/nfsd/nfsd ${D}${sbindir}/nfsd
55 install -m 0755 ${S}/utils/nfsstat/nfsstat ${D}${sbindir}/nfsstat
56 install -m 0755 ${S}/utils/showmount/showmount ${D}${sbindir}/showmount
57 install -m 0755 ${S}/utils/statd/statd ${D}${sbindir}/statd
59 ln -s ${D}/${base_sbindir}/mount.nfs ${D}/${base_sbindir}/mount.nfs4
61 install -d ${D}${mandir}/man8
62 install -m 0644 ${S}/utils/exportfs/exportfs.man ${D}${mandir}/man8/exportfs.8
63 install -m 0644 ${S}/utils/mountd/mountd.man ${D}${mandir}/man8/mountd.8
64 install -m 0644 ${S}/utils/nfsd/nfsd.man ${D}${mandir}/man8/nfsd.8
65 install -m 0644 ${S}/utils/nfsstat/nfsstat.man ${D}${mandir}/man8/nfsstat.8
66 install -m 0644 ${S}/utils/showmount/showmount.man ${D}${mandir}/man8/showmount.8
67 install -m 0644 ${S}/utils/statd/statd.man ${D}${mandir}/man8/statd.8
70 PACKAGES =+ "nfs-utils-client"
71 FILES_nfs-utils-client = "${base_sbindir}/mount.nfs ${base_sbindir}/mount.nfs4"