uclibc: remove obsolete patches for git version
[openembedded.git] / recipes / prboom / prboom_2.5.0.bb
blob92a276dcad100234de5b79016540bf5bb975f30a
1 DESCRIPTION = "A Doom Clone based on SDL"
2 SECTION = "games"
3 PRIORITY = "optional"
4 DEPENDS = "virtual/libsdl libsdl-mixer libsdl-net"
5 LICENSE = "GPL"
7 PR = "r2"
8 RRECOMMENDS_${PN} = "freedoom"
10 SRC_URI = "${SOURCEFORGE_MIRROR}/prboom/prboom-${PV}.tar.gz \
13 inherit autotools
15 EXTRA_OECONF = " --disable-gl --disable-cpu-opt --without-x --disable-sdltest"
17 do_install() {
18 install -d ${D}${bindir} \
19 ${D}${datadir}/games/doom
21 install -m 0755 src/prboom ${D}${bindir}/prboom
22 install -m 0644 data/prboom.wad ${D}${datadir}/games/doom/
25 FILES_${PN} += "${datadir}/games/doom/prboom.wad"
27 SRC_URI[md5sum] = "a8a15f61fa2626ab98051ab2703378c4"
28 SRC_URI[sha256sum] = "226c1c470f8cc983327536404f405a1d026cf0a5188c694a1243cc8630014bae"