uclibc: remove obsolete patches for git version
[openembedded.git] / recipes / netkit-telnet / netkit-telnet_0.17.bb
blob39ac22850236c4bf79518431c7b88593166982a4
1 SECTION = "base"
2 DESCRIPTION = "netkit-telnet includes the telnet daemon and client."
3 DEPENDS = "ncurses"
4 LICENSE = "BSD"
5 PR = "r1"
7 SRC_URI = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-${PV}.tar.gz \
8 file://netkit-telnet-debian_0.17-36.diff \
9 file://cross-compile.patch "
11 LDFLAGS_libc-uclibc += " -lncurses"
13 do_configure () {
14 ./configure --prefix=${prefix}
16 # Inject our ldflags into the config... it is not horning them otherwise
17 echo "LDFLAGS=${LDFLAGS}" > MCONFIG
21 do_compile () {
22 oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' SUB=telnet
25 do_install () {
26 install -d ${D}${bindir}
27 install -m 0755 telnet/telnet ${D}${bindir}/telnet.${PN}
30 pkg_postinst_${PN} () {
31 #!/bin/sh
32 update-alternatives --install ${bindir}/telnet telnet telnet.${PN} 100
35 pkg_prerm_${PN} () {
36 #!/bin/sh
37 update-alternatives --remove telnet telnet.${PN} 100
41 SRC_URI[md5sum] = "d6beabaaf53fe6e382c42ce3faa05a36"
42 SRC_URI[sha256sum] = "9c80d5c7838361a328fb6b60016d503def9ce53ad3c589f3b08ff71a2bb88e00"