uclibc: remove obsolete patches for git version
[openembedded.git] / classes / package.bbclass
blobc3781330bba0a2ea6f509c19916e42aa1522f4dc
2 # General packaging help functions
5 PKGD    = "${WORKDIR}/package"
6 PKGDEST = "${WORKDIR}/packages-split"
8 PKGV    ?= "${PV}"
9 PKGR    ?= "${PR}${DISTRO_PR}"
11 EXTENDPKGEVER = "${@['','${PKGE\x7d:'][bb.data.getVar('PKGE',d,1) > 0]}"
12 EXTENDPKGV ?= "${EXTENDPKGEVER}${PKGV}-${PKGR}"
14 def legitimize_package_name(s):
15         """
16         Make sure package names are legitimate strings
17         """
18         import re
20         def fixutf(m):
21                 cp = m.group(1)
22                 if cp:
23                         return ('\u%s' % cp).decode('unicode_escape').encode('utf-8')
25         # Handle unicode codepoints encoded as <U0123>, as in glibc locale files.
26         s = re.sub('<U([0-9A-Fa-f]{1,4})>', fixutf, s)
28         # Remaining package name validity fixes
29         return s.lower().replace('_', '-').replace('@', '+').replace(',', '+').replace('/', '-')
31 def do_split_packages(d, root, file_regex, output_pattern, description, postinst=None, recursive=False, hook=None, extra_depends=None, aux_files_pattern=None, postrm=None, allow_dirs=False, prepend=False, match_path=False, aux_files_pattern_verbatim=None, allow_links=False):
32         """
33         Used in .bb files to split up dynamically generated subpackages of a 
34         given package, usually plugins or modules.
35         """
37         dvar = bb.data.getVar('PKGD', d, True)
39         packages = bb.data.getVar('PACKAGES', d, True).split()
41         if postinst:
42                 postinst = '#!/bin/sh\n' + postinst + '\n'
43         if postrm:
44                 postrm = '#!/bin/sh\n' + postrm + '\n'
45         if not recursive:
46                 objs = os.listdir(dvar + root)
47         else:
48                 objs = []
49                 for walkroot, dirs, files in os.walk(dvar + root):
50                         for file in files:
51                                 relpath = os.path.join(walkroot, file).replace(dvar + root + '/', '', 1)
52                                 if relpath:
53                                         objs.append(relpath)
55         if extra_depends == None:
56                 # This is *really* broken
57                 mainpkg = packages[0]
58                 # At least try and patch it up I guess...
59                 if mainpkg.find('-dbg'):
60                         mainpkg = mainpkg.replace('-dbg', '')
61                 if mainpkg.find('-dev'):
62                         mainpkg = mainpkg.replace('-dev', '')
63                 extra_depends = mainpkg
65         for o in objs:
66                 import re, stat
67                 if match_path:
68                         m = re.match(file_regex, o)
69                 else:
70                         m = re.match(file_regex, os.path.basename(o))
71                 
72                 if not m:
73                         continue
74                 f = os.path.join(dvar + root, o)
75                 mode = os.lstat(f).st_mode
76                 if not (stat.S_ISREG(mode) or (allow_links and stat.S_ISLNK(mode)) or (allow_dirs and stat.S_ISDIR(mode))):
77                         continue
78                 on = legitimize_package_name(m.group(1))
79                 pkg = output_pattern % on
80                 if not pkg in packages:
81                         if prepend:
82                                 packages = [pkg] + packages
83                         else:
84                                 packages.append(pkg)
85                         the_files = [os.path.join(root, o)]
86                         if aux_files_pattern:
87                                 if type(aux_files_pattern) is list:
88                                         for fp in aux_files_pattern:
89                                                 the_files.append(fp % on)       
90                                 else:
91                                         the_files.append(aux_files_pattern % on)
92                         if aux_files_pattern_verbatim:
93                                 if type(aux_files_pattern_verbatim) is list:
94                                         for fp in aux_files_pattern_verbatim:
95                                                 the_files.append(fp % m.group(1))       
96                                 else:
97                                         the_files.append(aux_files_pattern_verbatim % m.group(1))
98                         bb.data.setVar('FILES_' + pkg, " ".join(the_files), d)
99                         if extra_depends != '':
100                                 the_depends = bb.data.getVar('RDEPENDS_' + pkg, d, True)
101                                 if the_depends:
102                                         the_depends = '%s %s' % (the_depends, extra_depends)
103                                 else:
104                                         the_depends = extra_depends
105                                 bb.data.setVar('RDEPENDS_' + pkg, the_depends, d)
106                         bb.data.setVar('DESCRIPTION_' + pkg, description % on, d)
107                         if postinst:
108                                 bb.data.setVar('pkg_postinst_' + pkg, postinst, d)
109                         if postrm:
110                                 bb.data.setVar('pkg_postrm_' + pkg, postrm, d)
111                 else:
112                         oldfiles = bb.data.getVar('FILES_' + pkg, d, True)
113                         if not oldfiles:
114                                 bb.fatal("Package '%s' exists but has no files" % pkg)
115                         bb.data.setVar('FILES_' + pkg, oldfiles + " " + os.path.join(root, o), d)
116                 if callable(hook):
117                         hook(f, pkg, file_regex, output_pattern, m.group(1))
119         bb.data.setVar('PACKAGES', ' '.join(packages), d)
121 PACKAGE_DEPENDS += "file-native"
123 def package_stash_hook(func, name, d):
124         import bb, os.path
125         body = bb.data.getVar(func, d, True)
126         pn = bb.data.getVar('PN', d, True)
127         staging = bb.data.getVar('PKGDATA_DIR', d, True)
128         dirname = os.path.join(staging, 'hooks', name)
129         bb.mkdirhier(dirname)
130         fn = os.path.join(dirname, pn)
131         f = open(fn, 'w')
132         f.write("python () {\n");
133         f.write(body);
134         f.write("}\n");
135         f.close()
137 python () {
138     if bb.data.getVar('PACKAGES', d, True) != '':
139         deps = bb.data.getVarFlag('do_package', 'depends', d) or ""
140         for dep in (bb.data.getVar('PACKAGE_DEPENDS', d, True) or "").split():
141             deps += " %s:do_populate_sysroot" % dep
142         bb.data.setVarFlag('do_package', 'depends', deps, d)
144         deps = (bb.data.getVarFlag('do_package', 'deptask', d) or "").split()
145         # shlibs requires any DEPENDS to have already packaged for the *.list files
146         deps.append("do_package")
147         bb.data.setVarFlag('do_package', 'deptask', " ".join(deps), d)
150 def runstrip(file, d):
151     # Function to strip a single file, called from populate_packages below
152     # A working 'file' (one which works on the target architecture)
153     # is necessary for this stuff to work, hence the addition to do_package[depends]
155     import commands, stat
157     pathprefix = "export PATH=%s; " % bb.data.getVar('PATH', d, True)
159     ret, result = commands.getstatusoutput("%sfile '%s'" % (pathprefix, file))
161     if ret:
162         bb.error("runstrip: 'file %s' failed (forced strip)" % file)
164     if "not stripped" not in result:
165         bb.debug(1, "runstrip: skip %s" % file)
166         return 0
168     # If the file is in a .debug directory it was already stripped,
169     # don't do it again...
170     if os.path.dirname(file).endswith(".debug"):
171         bb.debug(2, "Already ran strip on %s" % file)
172         return 0
174     strip = bb.data.getVar("STRIP", d, True)
175     objcopy = bb.data.getVar("OBJCOPY", d, True)
177     newmode = None
178     if not os.access(file, os.W_OK):
179         origmode = os.stat(file)[stat.ST_MODE]
180         newmode = origmode | stat.S_IWRITE
181         os.chmod(file, newmode)
183     extraflags = ""
184     if ".so" in file and "shared" in result:
185         extraflags = "--remove-section=.comment --remove-section=.note --strip-unneeded"
186     elif "shared" in result or "executable" in result:
187         extraflags = "--remove-section=.comment --remove-section=.note"
188     elif file.endswith(".a"):
189         extraflags = "--remove-section=.comment --strip-debug"
192     bb.mkdirhier(os.path.join(os.path.dirname(file), ".debug"))
193     debugfile=os.path.join(os.path.dirname(file), ".debug", os.path.basename(file))
195     stripcmd = "'%s' %s '%s'" % (strip, extraflags, file)
196     bb.debug(1, "runstrip: %s" % stripcmd)
198     os.system("%s'%s' --only-keep-debug '%s' '%s'" % (pathprefix, objcopy, file, debugfile))
199     ret = os.system("%s%s" % (pathprefix, stripcmd))
200     if (bb.data.getVar('PACKAGE_STRIP', d, True) != 'full'):
201         os.system("%s'%s' --add-gnu-debuglink='%s' '%s'" % (pathprefix, objcopy, debugfile, file))
203     if newmode:
204         os.chmod(file, origmode)
206     if ret:
207         bb.error("runstrip: '%s' strip command failed" % stripcmd)
209     return 1
211 PACKAGESTRIPFUNCS += "do_runstrip"
212 python do_runstrip() {
213         import stat
215         dvar = bb.data.getVar('PKGD', d, True)
216         def isexec(path):
217                 try:
218                         s = os.stat(path)
219                 except (os.error, AttributeError):
220                         return 0
221                 return (s[stat.ST_MODE] & stat.S_IEXEC)
223         for root, dirs, files in os.walk(dvar):
224                 for f in files:
225                         file = os.path.join(root, f)
226                         if not os.path.islink(file) and not os.path.isdir(file) and isexec(file):
227                                 runstrip(file, d)
231 def write_package_md5sums (root, outfile, ignorepaths):
232     # For each regular file under root, writes an md5sum to outfile.
233     # With thanks to patch.bbclass.
234     import bb, os
236     try:
237         # Python 2.5+
238         import hashlib
239         ctor = hashlib.md5
240     except ImportError:
241         import md5
242         ctor = md5.new
244     outf = file(outfile, 'w')
246     # Each output line looks like: "<hex...>  <filename without leading slash>"
247     striplen = len(root)
248     if not root.endswith('/'):
249         striplen += 1
251     for walkroot, dirs, files in os.walk(root):
252         # Skip e.g. the DEBIAN directory
253         if walkroot[striplen:] in ignorepaths:
254             dirs[:] = []
255             continue
257         for name in files:
258             fullpath = os.path.join(walkroot, name)
259             if os.path.islink(fullpath) or (not os.path.isfile(fullpath)):
260                 continue
262             m = ctor()
263             f = file(fullpath, 'rb')
264             while True:
265                 d = f.read(8192)
266                 if not d:
267                     break
268                 m.update(d)
269             f.close()
271             print >> outf, "%s  %s" % (m.hexdigest(), fullpath[striplen:])
273     outf.close()
277 # Package data handling routines
280 def get_package_mapping (pkg, d):
281         data = read_subpkgdata(pkg, d)
282         key = "PKG_%s" % pkg
284         if key in data:
285                 return data[key]
287         return pkg
289 def runtime_mapping_rename (varname, d):
290         #bb.note("%s before: %s" % (varname, bb.data.getVar(varname, d, True))) 
292         new_depends = []
293         for depend in explode_deps(bb.data.getVar(varname, d, True) or ""):
294                 # Have to be careful with any version component of the depend
295                 split_depend = depend.split(' (')
296                 new_depend = get_package_mapping(split_depend[0].strip(), d)
297                 if len(split_depend) > 1:
298                         new_depends.append("%s (%s" % (new_depend, split_depend[1]))
299                 else:
300                         new_depends.append(new_depend)
302         bb.data.setVar(varname, " ".join(new_depends) or None, d)
304         #bb.note("%s after: %s" % (varname, bb.data.getVar(varname, d, True)))
307 # Package functions suitable for inclusion in PACKAGEFUNCS
310 python package_do_split_locales() {
311         if (bb.data.getVar('PACKAGE_NO_LOCALE', d, True) == '1'):
312                 bb.debug(1, "package requested not splitting locales")
313                 return
315         packages = (bb.data.getVar('PACKAGES', d, True) or "").split()
317         datadir = bb.data.getVar('datadir', d, True)
318         if not datadir:
319                 bb.note("datadir not defined")
320                 return
322         dvar = bb.data.getVar('PKGD', d, True)
323         pn = bb.data.getVar('PN', d, True)
325         if pn + '-locale' in packages:
326                 packages.remove(pn + '-locale')
328         localedir = os.path.join(dvar + datadir, 'locale')
330         if not os.path.isdir(localedir):
331                 bb.debug(1, "No locale files in this package")
332                 return
334         locales = os.listdir(localedir)
336         # This is *really* broken
337         mainpkg = packages[0]
338         # At least try and patch it up I guess...
339         if mainpkg.find('-dbg'):
340                 mainpkg = mainpkg.replace('-dbg', '')
341         if mainpkg.find('-dev'):
342                 mainpkg = mainpkg.replace('-dev', '')
344         for l in locales:
345                 ln = legitimize_package_name(l)
346                 pkg = pn + '-locale-' + ln
347                 packages.append(pkg)
348                 bb.data.setVar('FILES_' + pkg, os.path.join(datadir, 'locale', l), d)
349                 bb.data.setVar('RDEPENDS_' + pkg, '%s virtual-locale-%s' % (mainpkg, ln), d)
350                 bb.data.setVar('RPROVIDES_' + pkg, '%s-locale %s-translation' % (pn, ln), d)
351                 bb.data.setVar('DESCRIPTION_' + pkg, '%s translation for %s' % (l, pn), d)
353         bb.data.setVar('PACKAGES', ' '.join(packages), d)
356 python perform_packagecopy () {
357         dest = bb.data.getVar('D', d, True)
358         dvar = bb.data.getVar('PKGD', d, True)
360         bb.mkdirhier(dvar)
362         # Start by package population by taking a copy of the installed 
363         # files to operate on
364         os.system('rm -rf %s/*' % (dvar))
365         os.system('cp -pPR %s/* %s/' % (dest, dvar))
368 python populate_packages () {
369         import glob, errno, re,os
371         workdir = bb.data.getVar('WORKDIR', d, True)
372         outdir = bb.data.getVar('DEPLOY_DIR', d, True)
373         dvar = bb.data.getVar('PKGD', d, True)
374         packages = bb.data.getVar('PACKAGES', d, True)
375         pn = bb.data.getVar('PN', d, True)
377         bb.mkdirhier(outdir)
378         os.chdir(dvar)
380         # Sanity check PACKAGES for duplicates - should be moved to 
381         # sanity.bbclass once we have the infrastucture
382         package_list = []
383         for pkg in packages.split():
384                 if pkg in package_list:
385                         bb.error("-------------------")
386                         bb.error("%s is listed in PACKAGES multiple times, this leads to packaging errors." % pkg)
387                         bb.error("Please fix the metadata/report this as bug to OE bugtracker.")
388                         bb.error("-------------------")
389                 else:
390                         package_list.append(pkg)
393         if (bb.data.getVar('PACKAGE_STRIP', d, True) != 'no'):
394                 for f in (bb.data.getVar('PACKAGESTRIPFUNCS', d, True) or '').split():
395                         bb.build.exec_func(f, d)
397         pkgdest = bb.data.getVar('PKGDEST', d, True)
398         os.system('rm -rf %s' % pkgdest)
400         seen = []
401         main_is_empty = 1
402         main_pkg = bb.data.getVar('PN', d, True)
404         for pkg in package_list:
405                 localdata = bb.data.createCopy(d)
406                 root = os.path.join(pkgdest, pkg)
407                 bb.mkdirhier(root)
409                 bb.data.setVar('PKG', pkg, localdata)
410                 overrides = bb.data.getVar('OVERRIDES', localdata, True)
411                 if not overrides:
412                         raise bb.build.FuncFailed('OVERRIDES not defined')
413                 bb.data.setVar('OVERRIDES', overrides + ':' + pkg, localdata)
414                 bb.data.update_data(localdata)
416                 filesvar = bb.data.getVar('FILES', localdata, True) or ""
417                 files = filesvar.split()
418                 for file in files:
419                         if os.path.isabs(file):
420                                 file = '.' + file
421                         if not os.path.islink(file):
422                                 if os.path.isdir(file):
423                                         newfiles =  [ os.path.join(file,x) for x in os.listdir(file) ]
424                                         if newfiles:
425                                                 files += newfiles
426                                                 continue
427                         globbed = glob.glob(file)
428                         if globbed:
429                                 if [ file ] != globbed:
430                                         if not file in globbed:
431                                                 files += globbed
432                                                 continue
433                                         else:
434                                                 globbed.remove(file)
435                                                 files += globbed
436                         if (not os.path.islink(file)) and (not os.path.exists(file)):
437                                 continue
438                         if file in seen:
439                                 continue
440                         seen.append(file)
441                         if os.path.isdir(file) and not os.path.islink(file):
442                                 bb.mkdirhier(os.path.join(root,file))
443                                 os.chmod(os.path.join(root,file), os.stat(file).st_mode)
444                                 continue
445                         fpath = os.path.join(root,file)
446                         dpath = os.path.dirname(fpath)
447                         bb.mkdirhier(dpath)
448                         ret = bb.copyfile(file, fpath)
449                         if ret is False:
450                                 raise bb.build.FuncFailed("File population failed when copying %s to %s" % (file, fpath))
451                         if pkg == main_pkg and main_is_empty:
452                                 main_is_empty = 0
453                 del localdata
454         os.chdir(workdir)
456         unshipped = []
457         for root, dirs, files in os.walk(dvar):
458                 for f in files:
459                         path = os.path.join(root[len(dvar):], f)
460                         if ('.' + path) not in seen:
461                                 unshipped.append(path)
463         if unshipped != []:
464                 bb.note("the following files were installed but not shipped in any package:")
465                 for f in unshipped:
466                         bb.note("  " + f)
468         bb.build.exec_func("package_name_hook", d)
470         for pkg in package_list:
471                 pkgname = bb.data.getVar('PKG_%s' % pkg, d, True)
472                 if pkgname is None:
473                         bb.data.setVar('PKG_%s' % pkg, pkg, d)
475         dangling_links = {}
476         pkg_files = {}
477         for pkg in package_list:
478                 dangling_links[pkg] = []
479                 pkg_files[pkg] = []
480                 inst_root = os.path.join(pkgdest, pkg)
481                 for root, dirs, files in os.walk(inst_root):
482                         for f in files:
483                                 path = os.path.join(root, f)
484                                 rpath = path[len(inst_root):]
485                                 pkg_files[pkg].append(rpath)
486                                 try:
487                                         s = os.stat(path)
488                                 except OSError, (err, strerror):
489                                         if err != errno.ENOENT:
490                                                 raise
491                                         target = os.readlink(path)
492                                         if target[0] != '/':
493                                                 target = os.path.join(root[len(inst_root):], target)
494                                         dangling_links[pkg].append(os.path.normpath(target))
496         for pkg in package_list:
497                 rdepends = explode_deps(bb.data.getVar('RDEPENDS_' + pkg, d, 0) or bb.data.getVar('RDEPENDS', d, 0) or "")
499                 remstr = "${PN} (= ${EXTENDPKGV})"
500                 if main_is_empty and remstr in rdepends:
501                         rdepends.remove(remstr)
502                 for l in dangling_links[pkg]:
503                         found = False
504                         bb.debug(1, "%s contains dangling link %s" % (pkg, l))
505                         for p in package_list:
506                                 for f in pkg_files[p]:
507                                         if f == l:
508                                                 found = True
509                                                 bb.debug(1, "target found in %s" % p)
510                                                 if p == pkg:
511                                                         break
512                                                 if not p in rdepends:
513                                                         rdepends.append(p)
514                                                 break
515                         if found == False:
516                                 bb.note("%s contains dangling symlink to %s" % (pkg, l))
517                 bb.data.setVar('RDEPENDS_' + pkg, " " + " ".join(rdepends), d)
519 populate_packages[dirs] = "${D}"
521 python emit_pkgdata() {
522         from glob import glob
524         def write_if_exists(f, pkg, var):
525                 def encode(str):
526                         import codecs
527                         c = codecs.getencoder("string_escape")
528                         return c(str)[0]
530                 val = bb.data.getVar('%s_%s' % (var, pkg), d, True)
531                 if val:
532                         f.write('%s_%s: %s\n' % (var, pkg, encode(val)))
533                         return
534                 val = bb.data.getVar('%s' % (var), d, True)
535                 if val:
536                         f.write('%s: %s\n' % (var, encode(val)))
537                 return
539         packages = bb.data.getVar('PACKAGES', d, True)
540         pkgdest = bb.data.getVar('PKGDEST', d, 1)
541         pkgdatadir = bb.data.getVar('PKGDATA_DIR', d, True)
543         pstageactive = bb.data.getVar('PSTAGING_ACTIVE', d, True)
544         if pstageactive == "1":
545                 lf = bb.utils.lockfile(bb.data.expand("${STAGING_DIR}/staging.lock", d))
547         data_file = pkgdatadir + bb.data.expand("/${PN}" , d)
548         f = open(data_file, 'w')
549         f.write("PACKAGES: %s\n" % packages)
550         f.close()
551         package_stagefile(data_file, d)
553         workdir = bb.data.getVar('WORKDIR', d, True)
555         for pkg in packages.split():
556                 subdata_file = pkgdatadir + "/runtime/%s" % pkg
557                 sf = open(subdata_file, 'w')
558                 write_if_exists(sf, pkg, 'PN')
559                 write_if_exists(sf, pkg, 'PV')
560                 write_if_exists(sf, pkg, 'PR')
561                 write_if_exists(sf, pkg, 'PKGV')
562                 write_if_exists(sf, pkg, 'PKGR')
563                 write_if_exists(sf, pkg, 'DESCRIPTION')
564                 write_if_exists(sf, pkg, 'RDEPENDS')
565                 write_if_exists(sf, pkg, 'RPROVIDES')
566                 write_if_exists(sf, pkg, 'RRECOMMENDS')
567                 write_if_exists(sf, pkg, 'RSUGGESTS')
568                 write_if_exists(sf, pkg, 'RREPLACES')
569                 write_if_exists(sf, pkg, 'RCONFLICTS')
570                 write_if_exists(sf, pkg, 'PKG')
571                 write_if_exists(sf, pkg, 'ALLOW_EMPTY')
572                 write_if_exists(sf, pkg, 'FILES')
573                 write_if_exists(sf, pkg, 'pkg_postinst')
574                 write_if_exists(sf, pkg, 'pkg_postrm')
575                 write_if_exists(sf, pkg, 'pkg_preinst')
576                 write_if_exists(sf, pkg, 'pkg_prerm')
577                 sf.close()
579                 package_stagefile(subdata_file, d)
580                 #if pkgdatadir2:
581                 #       bb.copyfile(subdata_file, pkgdatadir2 + "/runtime/%s" % pkg)
583                 allow_empty = bb.data.getVar('ALLOW_EMPTY_%s' % pkg, d, True)
584                 if not allow_empty:
585                         allow_empty = bb.data.getVar('ALLOW_EMPTY', d, True)
586                 root = "%s/%s" % (pkgdest, pkg)
587                 os.chdir(root)
588                 g = glob('*') + glob('.[!.]*')
589                 if g or allow_empty == "1":
590                         packagedfile = pkgdatadir + '/runtime/%s.packaged' % pkg
591                         file(packagedfile, 'w').close()
592                         package_stagefile(packagedfile, d)
593         if pstageactive == "1":
594                 bb.utils.unlockfile(lf)
596 emit_pkgdata[dirs] = "${PKGDATA_DIR}/runtime"
598 ldconfig_postinst_fragment() {
599 if [ x"$D" = "x" ]; then
600         if [ -e /etc/ld.so.conf ] ; then
601                 [ -x /sbin/ldconfig ] && /sbin/ldconfig
602         fi
606 SHLIBSDIR = "${STAGING_DIR_HOST}/shlibs"
608 python package_do_shlibs() {
609         import re
611         exclude_shlibs = bb.data.getVar('EXCLUDE_FROM_SHLIBS', d, 0)
612         if exclude_shlibs:
613                 bb.debug(1, "not generating shlibs")
614                 return
615                 
616         lib_re = re.compile("^lib.*\.so")
617         libdir_re = re.compile(".*/lib$")
619         packages = bb.data.getVar('PACKAGES', d, True)
621         workdir = bb.data.getVar('WORKDIR', d, True)
623         ver = bb.data.getVar('PKGV', d, True)
624         if not ver:
625                 bb.error("PKGV not defined")
626                 return
628         pkgdest = bb.data.getVar('PKGDEST', d, True)
630         shlibs_dir = bb.data.getVar('SHLIBSDIR', d, True)
631         bb.mkdirhier(shlibs_dir)
633         pstageactive = bb.data.getVar('PSTAGING_ACTIVE', d, True)
634         if pstageactive == "1":
635                 lf = bb.utils.lockfile(bb.data.expand("${STAGING_DIR}/staging.lock", d))
637         if bb.data.getVar('PACKAGE_SNAP_LIB_SYMLINKS', d, True) == "1":
638                 snap_symlinks = True
639         else:
640                 snap_symlinks = False
642         if (bb.data.getVar('USE_LDCONFIG', d, True) or "1") == "1":
643                 use_ldconfig = True
644         else:
645                 use_ldconfig = False
647         needed = {}
648         private_libs = bb.data.getVar('PRIVATE_LIBS', d, True)
649         for pkg in packages.split():
650                 needs_ldconfig = False
651                 bb.debug(2, "calculating shlib provides for %s" % pkg)
653                 pkgver = bb.data.getVar('PKGV_' + pkg, d, True)
654                 if not pkgver:
655                         pkgver = bb.data.getVar('PV_' + pkg, d, True)
656                 if not pkgver:
657                         pkgver = ver
659                 needed[pkg] = []
660                 sonames = list()
661                 top = os.path.join(pkgdest, pkg)
662                 renames = []
663                 for root, dirs, files in os.walk(top):
664                         for file in files:
665                                 soname = None
666                                 path = os.path.join(root, file)
667                                 if (os.access(path, os.X_OK) or lib_re.match(file)) and not os.path.islink(path):
668                                         cmd = bb.data.getVar('OBJDUMP', d, True) + " -p " + path + " 2>/dev/null"
669                                         cmd = "PATH=\"%s\" %s" % (bb.data.getVar('PATH', d, True), cmd)
670                                         fd = os.popen(cmd)
671                                         lines = fd.readlines()
672                                         fd.close()
673                                         for l in lines:
674                                                 m = re.match("\s+NEEDED\s+([^\s]*)", l)
675                                                 if m:
676                                                         needed[pkg].append(m.group(1))
677                                                 m = re.match("\s+SONAME\s+([^\s]*)", l)
678                                                 if m:
679                                                         this_soname = m.group(1)
680                                                         if not this_soname in sonames:
681                                                                 # if library is private (only used by package) then do not build shlib for it
682                                                                 if not private_libs or -1 == private_libs.find(this_soname):
683                                                                         sonames.append(this_soname)
684                                                         if libdir_re.match(root):
685                                                                 needs_ldconfig = True
686                                                         if snap_symlinks and (file != soname):
687                                                                 renames.append((path, os.path.join(root, this_soname)))
688                 for (old, new) in renames:
689                         os.rename(old, new)
690                 shlibs_file = os.path.join(shlibs_dir, pkg + ".list")
691                 if os.path.exists(shlibs_file):
692                         os.remove(shlibs_file)
693                 shver_file = os.path.join(shlibs_dir, pkg + ".ver")
694                 if os.path.exists(shver_file):
695                         os.remove(shver_file)
696                 if len(sonames):
697                         fd = open(shlibs_file, 'w')
698                         for s in sonames:
699                                 fd.write(s + '\n')
700                         fd.close()
701                         package_stagefile(shlibs_file, d)
702                         fd = open(shver_file, 'w')
703                         fd.write(pkgver + '\n')
704                         fd.close()
705                         package_stagefile(shver_file, d)
706                 if needs_ldconfig and use_ldconfig:
707                         bb.debug(1, 'adding ldconfig call to postinst for %s' % pkg)
708                         postinst = bb.data.getVar('pkg_postinst_%s' % pkg, d, True) or bb.data.getVar('pkg_postinst', d, True)
709                         if not postinst:
710                                 postinst = '#!/bin/sh\n'
711                         postinst += bb.data.getVar('ldconfig_postinst_fragment', d, True)
712                         bb.data.setVar('pkg_postinst_%s' % pkg, postinst, d)
714         if pstageactive == "1":
715                 bb.utils.unlockfile(lf)
717         shlib_provider = {}
718         list_re = re.compile('^(.*)\.list$')
719         for dir in [shlibs_dir]: 
720                 if not os.path.exists(dir):
721                         continue
722                 for file in os.listdir(dir):
723                         m = list_re.match(file)
724                         if m:
725                                 dep_pkg = m.group(1)
726                                 fd = open(os.path.join(dir, file))
727                                 lines = fd.readlines()
728                                 fd.close()
729                                 ver_file = os.path.join(dir, dep_pkg + '.ver')
730                                 lib_ver = None
731                                 if os.path.exists(ver_file):
732                                         fd = open(ver_file)
733                                         lib_ver = fd.readline().rstrip()
734                                         fd.close()
735                                 for l in lines:
736                                         shlib_provider[l.rstrip()] = (dep_pkg, lib_ver)
738         assumed_libs = bb.data.getVar('ASSUME_SHLIBS', d, True)
739         if assumed_libs:
740             for e in assumed_libs.split():
741                 l, dep_pkg = e.split(":")
742                 lib_ver = None
743                 dep_pkg = dep_pkg.rsplit("_", 1)
744                 if len(dep_pkg) == 2:
745                     lib_ver = dep_pkg[1]
746                 dep_pkg = dep_pkg[0]
747                 shlib_provider[l] = (dep_pkg, lib_ver)
749         dep_packages = []
750         for pkg in packages.split():
751                 bb.debug(2, "calculating shlib requirements for %s" % pkg)
753                 deps = list()
754                 for n in needed[pkg]:
755                         if n in shlib_provider.keys():
756                                 (dep_pkg, ver_needed) = shlib_provider[n]
758                                 if dep_pkg == pkg:
759                                         continue
761                                 if ver_needed:
762                                         dep = "%s (>= %s)" % (dep_pkg, ver_needed)
763                                 else:
764                                         dep = dep_pkg
765                                 if not dep in deps:
766                                         deps.append(dep)
767                                 if not dep_pkg in dep_packages:
768                                         dep_packages.append(dep_pkg)
769                                         
770                         else:
771                                 bb.note("Couldn't find shared library provider for %s" % n)
773                 deps_file = os.path.join(pkgdest, pkg + ".shlibdeps")
774                 if os.path.exists(deps_file):
775                         os.remove(deps_file)
776                 if len(deps):
777                         fd = open(deps_file, 'w')
778                         for dep in deps:
779                                 fd.write(dep + '\n')
780                         fd.close()
783 python package_do_pkgconfig () {
784         import re
786         packages = bb.data.getVar('PACKAGES', d, True)
787         workdir = bb.data.getVar('WORKDIR', d, True)
788         pkgdest = bb.data.getVar('PKGDEST', d, True)
790         shlibs_dir = bb.data.getVar('SHLIBSDIR', d, True)
791         bb.mkdirhier(shlibs_dir)
793         pc_re = re.compile('(.*)\.pc$')
794         var_re = re.compile('(.*)=(.*)')
795         field_re = re.compile('(.*): (.*)')
797         pkgconfig_provided = {}
798         pkgconfig_needed = {}
799         for pkg in packages.split():
800                 pkgconfig_provided[pkg] = []
801                 pkgconfig_needed[pkg] = []
802                 top = os.path.join(pkgdest, pkg)
803                 for root, dirs, files in os.walk(top):
804                         for file in files:
805                                 m = pc_re.match(file)
806                                 if m:
807                                         pd = bb.data.init()
808                                         name = m.group(1)
809                                         pkgconfig_provided[pkg].append(name)
810                                         path = os.path.join(root, file)
811                                         if not os.access(path, os.R_OK):
812                                                 continue
813                                         f = open(path, 'r')
814                                         lines = f.readlines()
815                                         f.close()
816                                         for l in lines:
817                                                 m = var_re.match(l)
818                                                 if m:
819                                                         name = m.group(1)
820                                                         val = m.group(2)
821                                                         bb.data.setVar(name, bb.data.expand(val, pd), pd)
822                                                         continue
823                                                 m = field_re.match(l)
824                                                 if m:
825                                                         hdr = m.group(1)
826                                                         exp = bb.data.expand(m.group(2), pd)
827                                                         if hdr == 'Requires':
828                                                                 pkgconfig_needed[pkg] += exp.replace(',', ' ').split()
830         pstageactive = bb.data.getVar('PSTAGING_ACTIVE', d, True)
831         if pstageactive == "1":
832                 lf = bb.utils.lockfile(bb.data.expand("${STAGING_DIR}/staging.lock", d))
834         for pkg in packages.split():
835                 pkgs_file = os.path.join(shlibs_dir, pkg + ".pclist")
836                 if os.path.exists(pkgs_file):
837                         os.remove(pkgs_file)
838                 if pkgconfig_provided[pkg] != []:
839                         f = open(pkgs_file, 'w')
840                         for p in pkgconfig_provided[pkg]:
841                                 f.write('%s\n' % p)
842                         f.close()
843                         package_stagefile(pkgs_file, d)
845         for dir in [shlibs_dir]:
846                 if not os.path.exists(dir):
847                         continue
848                 for file in os.listdir(dir):
849                         m = re.match('^(.*)\.pclist$', file)
850                         if m:
851                                 pkg = m.group(1)
852                                 fd = open(os.path.join(dir, file))
853                                 lines = fd.readlines()
854                                 fd.close()
855                                 pkgconfig_provided[pkg] = []
856                                 for l in lines:
857                                         pkgconfig_provided[pkg].append(l.rstrip())
859         for pkg in packages.split():
860                 deps = []
861                 for n in pkgconfig_needed[pkg]:
862                         found = False
863                         for k in pkgconfig_provided.keys():
864                                 if n in pkgconfig_provided[k]:
865                                         if k != pkg and not (k in deps):
866                                                 deps.append(k)
867                                         found = True
868                         if found == False:
869                                 bb.note("couldn't find pkgconfig module '%s' in any package" % n)
870                 deps_file = os.path.join(pkgdest, pkg + ".pcdeps")
871                 if os.path.exists(deps_file):
872                         os.remove(deps_file)
873                 if len(deps):
874                         fd = open(deps_file, 'w')
875                         for dep in deps:
876                                 fd.write(dep + '\n')
877                         fd.close()
878                         package_stagefile(deps_file, d)
880         if pstageactive == "1":
881                 bb.utils.unlockfile(lf)
884 python read_shlibdeps () {
885         packages = bb.data.getVar('PACKAGES', d, True).split()
886         for pkg in packages:
887                 rdepends = explode_deps(bb.data.getVar('RDEPENDS_' + pkg, d, 0) or bb.data.getVar('RDEPENDS', d, 0) or "")
888                 for extension in ".shlibdeps", ".pcdeps", ".clilibdeps":
889                         depsfile = bb.data.expand("${PKGDEST}/" + pkg + extension, d)
890                         if os.access(depsfile, os.R_OK):
891                                 fd = file(depsfile)
892                                 lines = fd.readlines()
893                                 fd.close()
894                                 for l in lines:
895                                         rdepends.append(l.rstrip())
896                 bb.data.setVar('RDEPENDS_' + pkg, " " + " ".join(rdepends), d)
899 python package_depchains() {
900         """
901         For a given set of prefix and postfix modifiers, make those packages
902         RRECOMMENDS on the corresponding packages for its RDEPENDS.
904         Example:  If package A depends upon package B, and A's .bb emits an
905         A-dev package, this would make A-dev Recommends: B-dev.
907         If only one of a given suffix is specified, it will take the RRECOMMENDS
908         based on the RDEPENDS of *all* other packages. If more than one of a given 
909         suffix is specified, its will only use the RDEPENDS of the single parent 
910         package.
911         """
913         packages  = bb.data.getVar('PACKAGES', d, True)
914         postfixes = (bb.data.getVar('DEPCHAIN_POST', d, True) or '').split()
915         prefixes  = (bb.data.getVar('DEPCHAIN_PRE', d, True) or '').split()
917         def pkg_adddeprrecs(pkg, base, suffix, getname, depends, d):
919                 #bb.note('depends for %s is %s' % (base, depends))
920                 rreclist = explode_deps(bb.data.getVar('RRECOMMENDS_' + pkg, d, True) or bb.data.getVar('RRECOMMENDS', d, True) or "")
922                 for depend in depends:
923                         if depend.find('-native') != -1 or depend.find('-cross') != -1 or depend.startswith('virtual/'):
924                                 #bb.note("Skipping %s" % depend)
925                                 continue
926                         if depend.endswith('-dev'):
927                                 depend = depend.replace('-dev', '')
928                         if depend.endswith('-dbg'):
929                                 depend = depend.replace('-dbg', '')
930                         pkgname = getname(depend, suffix)
931                         #bb.note("Adding %s for %s" % (pkgname, depend))
932                         if not pkgname in rreclist:
933                                 rreclist.append(pkgname)
935                 #bb.note('setting: RRECOMMENDS_%s=%s' % (pkg, ' '.join(rreclist)))
936                 bb.data.setVar('RRECOMMENDS_%s' % pkg, ' '.join(rreclist), d)
938         def pkg_addrrecs(pkg, base, suffix, getname, rdepends, d):
940                 #bb.note('rdepends for %s is %s' % (base, rdepends))
941                 rreclist = explode_deps(bb.data.getVar('RRECOMMENDS_' + pkg, d, True) or bb.data.getVar('RRECOMMENDS', d, True) or "")
943                 for depend in rdepends:
944                         if depend.endswith('-dev'):
945                                 depend = depend.replace('-dev', '')
946                         if depend.endswith('-dbg'):
947                                 depend = depend.replace('-dbg', '')
948                         pkgname = getname(depend, suffix)
949                         if not pkgname in rreclist:
950                                 rreclist.append(pkgname)
952                 #bb.note('setting: RRECOMMENDS_%s=%s' % (pkg, ' '.join(rreclist)))
953                 bb.data.setVar('RRECOMMENDS_%s' % pkg, ' '.join(rreclist), d)
955         def add_dep(list, dep):
956                 dep = dep.split(' (')[0].strip()
957                 if dep not in list:
958                         list.append(dep)
960         depends = []
961         for dep in explode_deps(bb.data.getVar('DEPENDS', d, True) or ""):
962                 add_dep(depends, dep)
964         rdepends = []
965         for dep in explode_deps(bb.data.getVar('RDEPENDS', d, True) or ""):
966                 add_dep(rdepends, dep)
968         for pkg in packages.split():
969                 for dep in explode_deps(bb.data.getVar('RDEPENDS_' + pkg, d, True) or ""):
970                         add_dep(rdepends, dep)
972         #bb.note('rdepends is %s' % rdepends)
974         def post_getname(name, suffix):
975                 return '%s%s' % (name, suffix)
976         def pre_getname(name, suffix):
977                 return '%s%s' % (suffix, name)
979         pkgs = {}
980         for pkg in packages.split():
981                 for postfix in postfixes:
982                         if pkg.endswith(postfix):
983                                 if not postfix in pkgs:
984                                         pkgs[postfix] = {}
985                                 pkgs[postfix][pkg] = (pkg[:-len(postfix)], post_getname)
987                 for prefix in prefixes:
988                         if pkg.startswith(prefix):
989                                 if not prefix in pkgs:
990                                         pkgs[prefix] = {}
991                                 pkgs[prefix][pkg] = (pkg[:-len(prefix)], pre_getname)
993         for suffix in pkgs:
994                 for pkg in pkgs[suffix]:
995                         (base, func) = pkgs[suffix][pkg]
996                         if suffix == "-dev" and not pkg.startswith("kernel-module-"):
997                                 pkg_adddeprrecs(pkg, base, suffix, func, depends, d)
998                         if len(pkgs[suffix]) == 1:
999                                 pkg_addrrecs(pkg, base, suffix, func, rdepends, d)
1000                         else:
1001                                 rdeps = []
1002                                 for dep in explode_deps(bb.data.getVar('RDEPENDS_' + base, d, True) or bb.data.getVar('RDEPENDS', d, True) or ""):
1003                                         add_dep(rdeps, dep)
1004                                 pkg_addrrecs(pkg, base, suffix, func, rdeps, d)
1007 PACKAGE_PREPROCESS_FUNCS ?= ""
1008 PACKAGEFUNCS ?= "perform_packagecopy \
1009                 ${PACKAGE_PREPROCESS_FUNCS} \
1010                 package_do_split_locales \
1011                 populate_packages \
1012                 package_do_shlibs \
1013                 package_do_pkgconfig \
1014                 read_shlibdeps \
1015                 package_depchains \
1016                 emit_pkgdata"
1018 def package_run_hooks(f, d):
1019         import bb, os
1020         staging = bb.data.getVar('PKGDATA_DIR', d, True)
1021         dn = os.path.join(staging, 'hooks', f)
1022         if os.access(dn, os.R_OK):
1023                 for f in os.listdir(dn):
1024                         fn = os.path.join(dn, f)
1025                         fp = open(fn, 'r')
1026                         line = 0
1027                         for l in fp.readlines():
1028                                 l = l.rstrip()
1029                                 bb.parse.parse_py.BBHandler.feeder(line, l, fn, os.path.basename(fn), d)
1030                                 line += 1
1031                         fp.close()
1032                         anonqueue = bb.data.getVar("__anonqueue", d, True) or []
1033                         body = [x['content'] for x in anonqueue]
1034                         flag = { 'python' : 1, 'func' : 1 }
1035                         bb.data.setVar("__anonfunc", "\n".join(body), d)
1036                         bb.data.setVarFlags("__anonfunc", flag, d)
1037                         try:
1038                                 t = bb.data.getVar('T', d)
1039                                 bb.data.setVar('T', '${TMPDIR}/', d)
1040                                 bb.build.exec_func("__anonfunc", d)
1041                                 bb.data.delVar('T', d)
1042                                 if t:
1043                                         bb.data.setVar('T', t, d)
1044                         except Exception, e:
1045                                 bb.msg.debug(1, bb.msg.domain.Parsing, "Exception when executing anonymous function: %s" % e)
1046                                 raise
1047                         bb.data.delVar("__anonqueue", d)
1048                         bb.data.delVar("__anonfunc", d)
1050 python package_do_package () {
1051         packages = (bb.data.getVar('PACKAGES', d, True) or "").split()
1052         if len(packages) < 1:
1053                 bb.debug(1, "No packages to build, skipping do_package")
1054                 return
1056         workdir = bb.data.getVar('WORKDIR', d, True)
1057         outdir = bb.data.getVar('DEPLOY_DIR', d, True)
1058         dest = bb.data.getVar('D', d, True)
1059         dvar = bb.data.getVar('PKGD', d, True)
1060         pn = bb.data.getVar('PN', d, True)
1062         if not workdir or not outdir or not dest or not dvar or not pn or not packages:
1063                 bb.error("WORKDIR, DEPLOY_DIR, D, PN and PKGD all must be defined, unable to package")
1064                 return
1066         for f in (bb.data.getVar('PACKAGEFUNCS', d, True) or '').split():
1067                 bb.build.exec_func(f, d)
1068                 package_run_hooks(f, d)
1070 do_package[dirs] = "${D}"
1071 addtask package before do_build after do_install
1073 # Dummy task to mark when all packaging is complete
1074 do_package_write () {
1075         :
1077 addtask package_write before do_build after do_package
1079 EXPORT_FUNCTIONS do_package do_package_write
1082 # Helper functions for the package writing classes
1085 python package_mapping_rename_hook () {
1086         """
1087         Rewrite variables to account for package renaming in things
1088         like debian.bbclass or manual PKG variable name changes
1089         """
1090         runtime_mapping_rename("RDEPENDS", d)
1091         runtime_mapping_rename("RRECOMMENDS", d)
1092         runtime_mapping_rename("RSUGGESTS", d)
1093         runtime_mapping_rename("RPROVIDES", d)
1094         runtime_mapping_rename("RREPLACES", d)
1095         runtime_mapping_rename("RCONFLICTS", d)
1098 EXPORT_FUNCTIONS mapping_rename_hook