merge of 'ebb880278ddb813fb7b527d822caeb57adc81179'
[openembedded.git] / classes / xfce.bbclass
blobecc00825bc418986c16bede52222ab3f61173ff6
1 # xfce.oeclass
2 # Copyright (C) 2004, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
5 # Global class to make it easier to maintain XFCE packages
7 HOMEPAGE = "http://www.xfce.org"
8 LICENSE = "LGPL-2"
9 DEPENDS += "startup-notification"
11 SRC_URI = "http://www.us.xfce.org/archive/xfce-${PV}/src/${PN}-${PV}.tar.bz2"
13 inherit autotools
15 EXTRA_OECONF += "--with-pluginsdir=${libdir}/xfce4/panel-plugins/"
17 # FIXME:  Put icons in their own package too?
19 FILES_${PN} += "${datadir}/icons/* ${datadir}/applications/* ${libdir}/xfce4/modules/*.so*"
20 FILES_${PN}-doc += "${datadir}/xfce4/doc"