matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / zbedic / libbedic_1.1.bb
blobf498024ff441dbc5454f67d3eed2b8749f417000
1 DESCRIPTION = "Library to handle bedic dictionary"
2 HOMEPAGE = "http://bedic.sourceforge.net/"
3 AUTHOR = "Rafal Mantiuk <rafm@users.sourceforge.net>"
4 SECTION = "opie/libs"
5 PRIORITY = "optional"
6 LICENSE = "GPL"
7 DEPENDS = "sqlite3"
8 APPTYPE = "binary"
9 APPDESKTOP = "${WORKDIR}/zbedic/misc"
10 PR = "r4"
12 SRC_URI = "${SOURCEFORGE_MIRROR}/bedic/libbedic_${PV}-0.tgz"
14 S = "${WORKDIR}"
16 inherit palmtop
17 # need to override this, because bedic contains exception handling
18 # pass VERSION as a string \\"${PV}.0\\"
19 export OE_QMAKE_CXXFLAGS="-fexceptions -fno-rtti ${CXXFLAGS} -DVERSION=\\"${PV}.0\\""
21 do_configure() {
22 qmake -project && qmake -makefile -t lib -spec ${QMAKESPEC} CONFIG=console CONFIG+=staticlib CONFIG+=sharedlib -after \
23 TARGET=bedic \
24 SOURCES-=src/xerox.cpp OBJECTS-=xerox.o \
25 SOURCES-=src/mkbedic.cpp OBJECTS-=mkbedic.o \
26 SOURCES-=src/test_dynamic_dictionary.cpp \
29 do_install() {
30 install -d ${D}${includedir}
31 install -m 0644 ${S}/include/*.h ${D}${includedir}
32 install -d ${D}${libdir}
33 oe_libinstall -a libbedic ${D}${libdir}
36 FILES_${PN}-dev = "${includedir} ${libdir}"
38 SRC_URI[md5sum] = "211ea5a881b5691ec7a1aedbe7fc406c"
39 SRC_URI[sha256sum] = "0cb299278f17d4580d9b1b56df8b7c356afb016f2a68ce7d13a8169f74e2a16b"