matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / woodstox / woodstox2_2.0.6.bb
blob46ed187e1371c5a0fc3351d84a220b1054164a0a
1 DESCRIPTION = "High-performance XML processor."
2 LICENSE = "AL2.0 LGPL2.1"
4 AUTHOR = "Codehaus"
5 HOMEPAGE = "http://woodstox.codehaus.org"
7 SRC_URI = "http://woodstox.codehaus.org/2.0.6/wstx-src.tar.gz"
9 S = "${WORKDIR}"
11 inherit java-library
13 DEPENDS = "fastjar-native"
15 do_compile() {
16 mkdir -p build/META-INF/services
18 javac -nowarn -sourcepath src/java -d build \
19 `find src/java/org -name "*.java"` \
20 `find src/java/com -name "*.java"`
22 cp -r src/resources/* build/META-INF/services
24 fastjar -C build -c -f ${JARFILENAME} .
27 SRC_URI[md5sum] = "3fc8e914d13316aa254b883a99fd2b85"
28 SRC_URI[sha256sum] = "e7ab2018865334a1b9b04161235192c2fdc7387baa422b576722db2011f75157"