matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / vtun / vtun_2.6.bb
blobddb988da81b7571e58a89b565fef09c5d6e01546
1 DESCRIPTION = "Virtual Tunnels over TCP/IP networks with traffic shaping, compression and encryption."
2 HOMEPAGE = "http://vtun.sourceforge.net/"
3 SECTION = "console/network"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "zlib lzo"
7 PR = "r1"
9 SRC_URI = "${SOURCEFORGE_MIRROR}/vtun/vtun-${PV}.tar.gz \
10 file://init \
11 file://makefile.in-ldflags.patch;striplevel=0"
13 S = "${WORKDIR}/vtun"
15 inherit autotools
17 do_configure() {
18 export BLOWFISH_HDR_DIR=${STAGING_INCDIR}/openssl
19 oe_runconf --with-lzo-headers=${STAGING_INCDIR} --with-ssl-headers=${STAGING_INCDIR}/openssl
22 do_install() {
23 oe_runmake INSTALL_OWNER="" DESTDIR=${D} install
24 install -d ${D}${sysconfdir}/init.d/
25 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/vtund
26 install ${S}/scripts/vtund-start.conf ${D}${sysconfdir}
29 CONFFILES_${PN}_nylon = "${sysconfdir}/vtund-start.conf ${sysconfdir}/vtund.conf"
31 SRC_URI[md5sum] = "309534fd03c5d13a19c43916f61f4bbf"
32 SRC_URI[sha256sum] = "fc80dac6d622fdb2db16d772edc6ff7d0023ee6eb5f2acb79d894ee30197c2e5"